Search found 5 matches

by n00bzill4
Tue Dec 11, 2012 12:58 pm
Forum: HELP!
Topic: JUNO 106 LED failure
Replies: 6
Views: 772

Re: JUNO 106 LED failure

Well I decided to throw caution to the wind, scraped back the insulating layer with a blade and there was definitely a break. http://i99.photobucket.com/albums/l319/schrickvr6/IMAG0573.jpg I had some conductive paint I'd used for a motherboard voltage mod years ago, I figured at worst I could just s...
by n00bzill4
Tue Dec 11, 2012 12:14 pm
Forum: HELP!
Topic: JUNO 106 LED failure
Replies: 6
Views: 772

Re: JUNO 106 LED failure

Image
by n00bzill4
Tue Dec 11, 2012 12:07 pm
Forum: HELP!
Topic: JUNO 106 LED failure
Replies: 6
Views: 772

Re: JUNO 106 LED failure

Thanks very much Rhino for the welcome and advice, I've cracked open the case and I'm pretty sure I've found the fault, the D55 track appears to have corroded through between the chorus and sawtooth LED. Please bear with me as I've only got minimal experience with this type of thing..... I have cond...
by n00bzill4
Tue Dec 11, 2012 12:56 am
Forum: HELP!
Topic: JUNO 106 LED failure
Replies: 6
Views: 772

JUNO 106 LED failure

Hey there, The LEDs for the sawtooth or square waveform select have both stopped working at the same time, the switches still function as they should though. I thought it was strange that both should drop out simultaneously unless if one went it would mean the other wouldn't work either? Or is there...
by n00bzill4
Thu Jul 26, 2012 10:20 pm
Forum: Gear For Sale
Topic: VSE - Good trader/seller thread
Replies: 2143
Views: 477365

Re: VSE - Good trader/seller thread

I bought a Spectral Audio Neptune 2 from Explorer, very helpful, I paid on the Thursday, he shipped from Belgium on the Friday and it arrived very well packed the next Thursday. Highly recommended!