Search found 12 matches

by orys
Thu Jul 05, 2018 5:22 am
Forum: HELP!
Topic: korg poly-61 not responding to pushbuttons
Replies: 23
Views: 8996

Re: korg poly-61 not responding to pushbuttons

They work but i have to press hard on some of them.
by orys
Wed Jul 04, 2018 7:51 pm
Forum: HELP!
Topic: korg poly-61 not responding to pushbuttons
Replies: 23
Views: 8996

Re: korg poly-61 not responding to pushbuttons

I'm sticking plastic pieces on the actual keys to make them press lower.
The prices they charge for contact strips are ridiculous.
by orys
Tue Jul 03, 2018 8:28 am
Forum: HELP!
Topic: korg poly-61 not responding to pushbuttons
Replies: 23
Views: 8996

Re: korg poly-61 not responding to pushbuttons

Ok, so both MCU's have a notch(indent) on the left side of the chip and pin1 starts on the bottom row left, so count 4 pins from the bottom left and check continuity on both MCUs from pin4 to pin4. I do see some traces that could possible be a problem, but lets get thru the initial problem of Hangi...
by orys
Mon Jul 02, 2018 9:59 pm
Forum: HELP!
Topic: korg poly-61 not responding to pushbuttons
Replies: 23
Views: 8996

Re: korg poly-61 not responding to pushbuttons

I've loaded all the factory presets and it seems that all functions work so far. Need to sort the keybed as there are keys missing and some keys don't work. I'll report soon with new findings but it seems to be working fine. The ICs that look like that is because i used some type of acid to clean th...
by orys
Mon Jul 02, 2018 8:43 pm
Forum: HELP!
Topic: korg poly-61 not responding to pushbuttons
Replies: 23
Views: 8996

Re: korg poly-61 not responding to pushbuttons

Which components are damaged.
I fixed it already.
Not sure if it's fixed but i found a broken trace and fixed it so it now plays but need to test further.
Will try to load the default presets and see how it goes.
by orys
Mon Jul 02, 2018 5:47 pm
Forum: HELP!
Topic: korg poly-61 not responding to pushbuttons
Replies: 23
Views: 8996

Re: korg poly-61 not responding to pushbuttons

Hi there! Sorry for the late reply but i was really busy at work and didn't get a chance to check the two MCUs you suggested. I didn't quite figure out which are pins no.4 on each MCU but anyhow from left right, up down there isn't continuity except if I've made every measurement wrong. Care to tell...
by orys
Wed Jun 20, 2018 10:30 am
Forum: HELP!
Topic: korg poly-61 not responding to pushbuttons
Replies: 23
Views: 8996

Re: korg poly-61 not responding to pushbuttons

Thanks for the info my friend.
I'll check it today and let you know!
by orys
Wed Jun 20, 2018 9:16 am
Forum: HELP!
Topic: korg poly-61 not responding to pushbuttons
Replies: 23
Views: 8996

Re: korg poly-61 not responding to pushbuttons

MCU's???
What are these?
by orys
Wed Jun 20, 2018 8:44 am
Forum: HELP!
Topic: korg poly-61 not responding to pushbuttons
Replies: 23
Views: 8996

Re: korg poly-61 not responding to pushbuttons

Yes i measured continuity and it seems to have no problem.
Could it be the ROM?
by orys
Sun Jun 03, 2018 11:51 am
Forum: HELP!
Topic: korg poly-61 not responding to pushbuttons
Replies: 23
Views: 8996

Re: korg poly-61 not responding to pushbuttons

Hey there! Have the same problem although mine was purchased as damaged and seems to be stuck on P5-61 and won't respond to any pushbuttons. Had battery corrosion but i managed to clean everything and have measured the CPU board which seems to work fine. I measured all the molex connectors everywher...
by orys
Thu Mar 22, 2018 7:24 pm
Forum: HELP!
Topic: Juno 60 problem with chorus stages
Replies: 1
Views: 617

Re: Juno 60 problem with chorus stages

SOUND SAMPLES First is with line out stereo and when listening with a set of headphones the output is mono. :( Second is through the phones output. The samples are in this row NO CHORUS - CHORUS 1 - CHORUS 2 - CHORUS 1 AND 2 https://soundcloud.com/orys/line-out-stereo https://soundcloud.com/orys/pho...
by orys
Thu Mar 22, 2018 6:27 pm
Forum: HELP!
Topic: Juno 60 problem with chorus stages
Replies: 1
Views: 617

Juno 60 problem with chorus stages

Hi there! Got this synth 5 years ago, and had it tested back then. Everything seemed to be ok other than the trigger button that was not working. Then it was kept in storage due to other projects. After going through a divorce and selling most of my gear in the last 2 years i took the Juno out of st...