Search found 34 matches

by Synthead
Mon Jul 25, 2011 2:12 am
Forum: HELP!
Topic: Juno-106 blowing 500mA SB fuses
Replies: 14
Views: 2518

Re: Juno-106 blowing 500mA SB fuses

It blowing after a long period vs immediately on the analog side is worrisome since it points to something in the circuit is crapping out after it warms up. If there anything obviously wrong function wise? Fast-blow fuses pop immediately when they go over the amperage they're designed for. Slow blo...
by Synthead
Fri Jul 22, 2011 6:17 am
Forum: HELP!
Topic: Juno-106 blowing 500mA SB fuses
Replies: 14
Views: 2518

Re: Juno-106 blowing 500mA SB fuses

None of the fuses in a 106 are spec'd as slow blow in the service manual... Which fuse number is it? The two fuses for the analog supply (F2 & F3) are 500mA, they are for the +/- 15 volt supply. Can you clarify if it is the mains fuse that is failing or a secondary fuse? If is F2 or F3, try disconn...
by Synthead
Mon Jun 27, 2011 1:05 am
Forum: HELP!
Topic: Juno-106 blowing 500mA SB fuses
Replies: 14
Views: 2518

Re: Juno-106 blowing 500mA SB fuses

Stab Frenzy wrote:Could just be that old fuses blow eventually, especially if the synth gets moved around a bit. Replace the fuse with one the same rating and it'll probably be fine, if it blows again you know you've got a problem.
Already did. It reliably blows fuses.
by Synthead
Sun Jun 26, 2011 10:08 pm
Forum: HELP!
Topic: Juno-106 blowing 500mA SB fuses
Replies: 14
Views: 2518

Juno-106 blowing 500mA SB fuses

I have a Juno-106 that blew the 500mA slow-blow fuse after leaving it on overnight. Could this be because of one of the voice modules? I thought that if a module blew, the synth would just have a voice gone, essentially making it a 5-polyphony synth. Or would it?