Korg M1

Discussions about anything analog, digital, MIDI, synth technology, techniques, theories and more.
Post Reply
paulus.d
Newbie
Newbie
Posts: 2
Joined: Sun Aug 13, 2017 7:13 pm

Korg M1

Post by paulus.d » Sat Aug 26, 2017 9:56 pm

Just swapped a JEN SX1000 monosynth for a Korg M1...The Korg is in a poor condition, but is working ..just what I wanted ..a nice refurb project..
Just one question.. I have output only on one jack . I've tested it by changing leads and swapping over output sockets ..I have stripped the PCB's out of the case as the keyboard and buttons need some attention...
Is there anything I should look for ? I know the power supply caps are quite suspect

Paul

paulus.d
Newbie
Newbie
Posts: 2
Joined: Sun Aug 13, 2017 7:13 pm

Re: Korg M1

Post by paulus.d » Sun Aug 27, 2017 9:17 pm

Have taken simple reading from the PSU...5v out is 6.83 volts, +12v out is near 16 volts . ... these readings are off load with nothing plugged in so are they right?
perhaps I shouldn't power the beast up again until I can get the PSU recapped

DavidH
Newbie
Newbie
Posts: 7
Joined: Sun Jul 16, 2017 5:02 pm
Gear: Hammond B3/122, MK1 Rhodes Stage, Farfisa Compact Duo/Binson Echorec2, Moog LP Stage II, Kurzweil K2600XS, Roland Super JX-10/PG800, Roland JD800, DX7

Re: Korg M1

Post by DavidH » Mon Aug 28, 2017 6:14 pm

You probably need to change the op-amp nearest to the dead jack socket. I've had to do this with Kurzweils. Agree PSU should be recapped in something this age.

Post Reply