Korg T3 distort on a lot of sounds on all outputs

Discussions about anything analog, digital, MIDI, synth technology, techniques, theories and more.

Korg T3 distort on a lot of sounds on all outputs

Postby Tomateck » Fri Jan 26, 2018 11:40 am

Hello guys,

I need your help and hope you'll can give me useful suggestions.

A lot of sounds on my Korg T3 have distorted audio on all outputs and headphone.
This are all operations I have tryed:
1) reload all global instrumens programs from factory bank
2) changed the 3V battery
3) changed alimentation cable
...
but nothing has helped me to solve the problem.

Anyone with this problem in the past? What do you think can solve?
Change the output board? The motherboard? remake all weldings on internal cards?

Please help me :banghead: .

Thanks
Tomateck
Newbie
Newbie
 
Posts: 4
Joined: Fri Jan 26, 2018 11:29 am

Re: Korg T3 distort on a lot of sounds on all outputs

Postby ItsMeOnly » Fri Jan 26, 2018 12:19 pm

Check voltage on the PSU, there's a very common problem with cold solders on old Korg power supplies, also one MOSFET breaks over time.
User avatar
ItsMeOnly
Active Member
Active Member
 
Posts: 289
Joined: Thu Dec 01, 2005 9:01 pm
Location: Warszawa, Poland
Gear: Wavestation, K3m, TG77, MOXF6, D-550, S2000, DeepMind 12;
Broken: DX100, 01R/W, U-220

Re: Korg T3 distort on a lot of sounds on all outputs

Postby Tomateck » Fri Jan 26, 2018 12:26 pm

ItsMeOnly wrote:Check voltage on the PSU, there's a very common problem with cold solders on old Korg power supplies, also one MOSFET breaks over time.

Thanks for your reply, I'm not so expert in technical field, I don't know that psu can kill audio quality.
I'll try your advice
Tomateck
Newbie
Newbie
 
Posts: 4
Joined: Fri Jan 26, 2018 11:29 am

Re: Korg T3 distort on a lot of sounds on all outputs

Postby baz99 » Fri Jan 26, 2018 2:10 pm

Most likely leaked caps in the output section. Korg synths from that period are well known for that. Check also the underside of the board.
baz99
Newbie
Newbie
 
Posts: 88
Joined: Sun May 25, 2014 9:19 am
Location: Europe

Re: Korg T3 distort on a lot of sounds on all outputs

Postby Tomateck » Sat Jan 27, 2018 10:39 am

baz99 wrote:Most likely leaked caps in the output section. Korg synths from that period are well known for that. Check also the underside of the board.


Thank you very much, today I will begin my attempts to recover the tool with your suggestions. I hope to be able to tell you right away that you are right.
Again, thanks
Tomateck
Newbie
Newbie
 
Posts: 4
Joined: Fri Jan 26, 2018 11:29 am

Re: Korg T3 distort on a lot of sounds on all outputs

Postby Tomateck » Thu Feb 01, 2018 1:18 am

ItsMeOnly wrote:Check voltage on the PSU, there's a very common problem with cold solders on old Korg power supplies, also one MOSFET breaks over time.


Today I've opened the instrument and noticed that the PSU is not the original but a combination of a 1/2 part of the original and another piece assembled together.
Here you can view the photos that I've shot: https://photos.app.goo.gl/ajxqn1xBT5nA6hoq2
I've also included a photo of the original psu downloaded from the web.
Do you think this non original psu can cause the distortion? What do you think about the state of the unit?
Thanks
Tomateck
Newbie
Newbie
 
Posts: 4
Joined: Fri Jan 26, 2018 11:29 am

Re: Korg T3 distort on a lot of sounds on all outputs

Postby ItsMeOnly » Thu Feb 01, 2018 11:10 am

Tomateck wrote:Do you think this non original psu can cause the distortion? What do you think about the state of the unit?
Thanks

As long as we won't see the output voltages, we won't know for sure - but the probability is high. it seems someone modded an AT PC power supply here, and omitted cooling.
User avatar
ItsMeOnly
Active Member
Active Member
 
Posts: 289
Joined: Thu Dec 01, 2005 9:01 pm
Location: Warszawa, Poland
Gear: Wavestation, K3m, TG77, MOXF6, D-550, S2000, DeepMind 12;
Broken: DX100, 01R/W, U-220


Return to General Synthesizers

Who is online

Users browsing this forum: Bing [Bot] and 32 guests