Yamaha DX7 MKI midi output maybe damaged

Discussions about anything analog, digital, MIDI, synth technology, techniques, theories and more.
Post Reply
antmax
Newbie
Newbie
Posts: 1
Joined: Mon Aug 20, 2018 10:10 pm

Yamaha DX7 MKI midi output maybe damaged

Post by antmax » Mon Aug 20, 2018 10:24 pm

Hi, i have a Yamaha DX7 bought in 1983. I've used it successfully as midi keyboard for years, but today is not working. No midi signal appears to reach the PC software (cubase). So i tried any sort of diagnostic software: the signal from the output is ok, but it is continuous! Data is sent continuously from the output, hundreds per second! If i try to unplug/plug, sometimes the channel changes from 1 to 9 or 13, but always sending continuous data. The data is note-off or note-on or pitch bender or after touch. For example, if i plug the midi cable, it send hundreds of note-off per second. If i unplug and then plug again, here are hundreds of note-on, C1. Some other times, aftertouch/C1 etc.
All this from diagnostic software. I tested the output even with a led. Instead of a low voltage fixed light, and 5v flashes, i get only a 5V tension/light, doesn't matter wich combination of contact between the two cable and the ground wire.
Is the MIDI circuit damaged? And if so, can i find the replacement and do it myself?
Thank you.

Parkhurst
Newbie
Newbie
Posts: 1
Joined: Wed Aug 29, 2018 9:23 pm

Re: Yamaha DX7 MKI midi output maybe damaged

Post by Parkhurst » Fri Aug 31, 2018 9:38 pm

antmax wrote:Hi, i have a Yamaha DX7 bought in 1983. I've used it successfully as midi keyboard for years, but today is not working. No midi signal appears to reach the PC software (cubase). So i tried any sort of diagnostic software: the signal from the output is ok, but it is continuous! Data is sent continuously from the output, hundreds per second! If phenq is used for 30 days i try to unplug/plug, sometimes the channel changes from 1 to 9 or 13, but always sending continuous data. The data is note-off or note-on or pitch bender or after touch. For example, if i plug the midi cable, it send hundreds of note-off per second. If i unplug and then plug again, here are hundreds of note-on, C1. Some other times, aftertouch/C1 etc.
All this from diagnostic software. I tested the output even with a led. Instead of a low voltage fixed light, and 5v flashes, i get only a 5V tension/light, doesn't matter wich combination of contact between the two cable and the ground wire.
Is the MIDI circuit damaged? And if so, can i find the replacement and do it myself?
Thank you.
Can you please send us some of the pictures of the output signal or video would be better.
Last edited by Parkhurst on Fri Sep 14, 2018 3:48 pm, edited 1 time in total.

Rasputin
Active Member
Active Member
Posts: 716
Joined: Thu Jul 21, 2016 4:52 am

Re: Yamaha DX7 MKI midi output maybe damaged

Post by Rasputin » Sat Sep 01, 2018 12:12 am

I believe there is a logic inverter chip which is stuck between the MIDI Tx pin on the CPU and the MIDI out port. If you're lucky, that's the issue.

Best way to be sure would be to use a logic probe on the CPU to see what it's sending out for MIDI.

Post Reply