Juno 60 - HPF Problems

Discussions about anything analog, digital, MIDI, synth technology, techniques, theories and more.
Post Reply
hiitsmichel
Newbie
Newbie
Posts: 1
Joined: Fri Jul 31, 2020 10:21 am

Juno 60 - HPF Problems

Post by hiitsmichel » Fri Jul 31, 2020 10:41 am

Hello everyone,

i'm having problems with my Juno 60 i just bought. i've been saving for a long time, and now, after a lot of ebay, i finally bought my dream synth.
At the first test everything seemed to be ok, but now, after I spent some time with it, I noticed a pretty serious mistake.

There are problems with the HPF. If I just touch the slider it jumps back and forth between the steps. When I push it up, it sometimes doesn't take the steps directly, only when I wiggle it back and forth a little it locks into the correct filter position. But that's not all, often the HPF jumps between the steps when I touch the adjacent faders like FREQ, RES, NOISE or the SUB. Just all faders that are located nearby on the board. What I also noticed is that when I press the HPF faders or the faders around them slightly from above, the filter also jumps to another level.

I don't have much experience with restoring vintage synths and I'm very careful with everything I do. I do have some experience in soldering, but I didn't want to just try around. I already had the Juno open, unscrewed the PCBs on top and cleaned all faders carefully with compressed air and propanol, but unfortunately this didn't solve the problem.

Now I hope you have some tips for me. Do I have to solder the fader out and clean it carefully? What do I have to consider when cleaning? Or can it not be due to dirt? What do I do if the fader is broken, because I found online replacements for all other sliders, except for the HPF.

I'm totally new here and don't know much yet, but I really want to learn a lot! So I'm happy about every help and tip for a twenty year old beginner in the vintage synth world :)

Thanks for any help and greetings,
michel

Post Reply