Jeff Mills: the early years

Discussions about anything analog, digital, MIDI, synth technology, techniques, theories and more.
Post Reply
User avatar
micahjonhughes
Active Member
Active Member
Posts: 703
Joined: Fri Mar 09, 2007 4:27 pm
Location: Chicago

Jeff Mills: the early years

Post by micahjonhughes » Mon Jul 30, 2007 2:07 am

I've always been interested in the synths used by Jeff Mills in the early 90s, but have unable to find much info. I especially love the Waveform Transmission and the X-103 albums. Besides the 909 anyone know what was used during this period?

Wiglaf
Active Member
Active Member
Posts: 254
Joined: Fri May 06, 2005 4:06 am
Real name: Tyler
Gear: I don't even remember half of it
Band: width full
Location: Michigan, U.S...but not Detroit

Post by Wiglaf » Mon Jul 30, 2007 5:06 am

Yamaha DX-any.

"The Bells" is a DX-200.
"I thought all you did was push a button and sounds came out!" - Mom on synths
"Not quite, Mom." - Me on synths

User avatar
micahjonhughes
Active Member
Active Member
Posts: 703
Joined: Fri Mar 09, 2007 4:27 pm
Location: Chicago

Post by micahjonhughes » Mon Jul 30, 2007 6:18 am

The Bells was out long before the DX 200.

In the later Purpose Maker records you mostly hearing a sampler. Many of the Purpose Maker tracks are built round samples from other techno and house tracks.

rockmanrock
Junior Member
Junior Member
Posts: 231
Joined: Thu Apr 06, 2006 8:47 pm

Post by rockmanrock » Mon Jul 30, 2007 7:54 am

EPS16+ on Waveform Transmission Vol 1 according to a post on discogs.com. I've also seen Yamaha TG33 and QY20 mentioned.

User avatar
Yoozer
Expert Member
Expert Member
Posts: 1390
Joined: Sun Oct 09, 2005 1:31 pm

Post by Yoozer » Mon Jul 30, 2007 7:57 pm

I think Wiglaf mistyped "DX-100" ;).
"Part of an instrument is what it can do, and part of it is what you do to it" - Suzanne Ciani, 197x.

Wiglaf
Active Member
Active Member
Posts: 254
Joined: Fri May 06, 2005 4:06 am
Real name: Tyler
Gear: I don't even remember half of it
Band: width full
Location: Michigan, U.S...but not Detroit

Post by Wiglaf » Tue Jul 31, 2007 4:17 am

Yoozer wrote:I think Wiglaf mistyped "DX-100" ;).
He did.
"I thought all you did was push a button and sounds came out!" - Mom on synths
"Not quite, Mom." - Me on synths

Post Reply