siel cruise repair

Discussions about anything analog, digital, MIDI, synth technology, techniques, theories and more.

siel cruise repair

Postby 1ajs » Tue Dec 20, 2016 10:34 pm

mine has flaked out

had no fuse when i got it got something there now

opened it up at one point as i had some dead keys found that the spring had fellen out of the switch mech on the keys easy fix

next i wanted to figure out why one of the poly didnt work so i was in side it looking and unseated and reseated all my ribbont cables now i have nothing

anyone know where to begin with this?
i unseted and reseatched a couple ic's found tanishing on their pins

tios on testing this no idea where to start be nice to get it working properly only paid 5 bucks it at a garage sale
ill get a video of what i see next time im at my workshop

Image

Image
1ajs
Newbie
Newbie
 
Posts: 7
Joined: Sun Jun 19, 2016 12:58 am

Re: siel cruise repair

Postby 1ajs » Sun Feb 19, 2017 1:51 am

anyone any advice on where to start like to get this up and going shame having it sit on my shelf
1ajs
Newbie
Newbie
 
Posts: 7
Joined: Sun Jun 19, 2016 12:58 am

Re: siel cruise repair

Postby 1ajs » Wed Feb 22, 2017 5:47 am

video of what its doing
Watch on youtube.com
1ajs
Newbie
Newbie
 
Posts: 7
Joined: Sun Jun 19, 2016 12:58 am

Re: siel cruise repair

Postby 1ajs » Sun Mar 05, 2017 1:03 am

Took this thing to a local synth gathering I organized here in Winnipeg today and put it on display as a this is what a synth looks like and got talking to a guy from Boeing who started looking at it and we Found a bad connection on pipn one of the cable that runs from the poly board to the keyboard. So the guy literaly started building one to test the theory. Bam I got poly back. Mono still broken though

The vibrator switch effects the right side mono led if off it turns the led off not affected by the mono button another thing is when I press a key with vibrator on the led fades out when a key is pressed do I have something crossed somewhere I had all the cables unplugged but can see anything obvious or possible another bad cable?
1ajs
Newbie
Newbie
 
Posts: 7
Joined: Sun Jun 19, 2016 12:58 am


Return to General Synthesizers

Who is online

Users browsing this forum: abruzzi and 1 guest