Roland Juno 60 - Panel board A and power issue.

The place for parts & services: Modifications, Spare Parts and Repair Services, Sample Packs, Accessories.
Forum rules
This forum follows the same rules outlined in Gear For Sale Rules and Guidelines

Moderators have the right to edit your posts to keep them within the framework of these rules.

Roland Juno 60 - Panel board A and power issue.

Postby c_mvrder » Tue Jul 24, 2018 7:20 pm

I just moved cities and in the move my juno 60 developed some issues. It started with the Appreg. and the square wave are no longer working. I am a pretty good with electronics and so I ordered a replacement tact switch for the Appreg. and soldered in the replacement. While I had the synth open I reflowed the whole panel A board hoping the the square wave issue was just a cold solder joint. This is when things started to go downhill. I put the board back in and now its completely unresponsive. The panel board B was working at first but now its no longer powering on, the patch led doesn't have power. The PSU on the synth did get super hot and has a smell....I have a multimeter and am starting to think that the transformer just went out, hopefully. Any help or advice would be great...I have a service manual and will be tinkering with it but I figured it wouldn't hurt to ask the collective mind.
-S
c_mvrder
Newbie
Newbie
 
Posts: 1
Joined: Tue Jul 24, 2018 7:04 pm

Return to Gear Services & Other Goods

Who is online

Users browsing this forum: No registered users and 2 guests