Page 1 of 1

M1 issue after battery change

Posted: Sat Jul 25, 2020 4:11 am
by Worthy
Hi, hoping someone can tell me if I've cooked a circuit board or something in my M1. It was very lightly used from new in Vancouver, then made a move to Singapore where PSU was replaced for 220V version and used there periodically. Then it was onto Bali where it has sat in storage for several years.

I recently decided to get back onto the music and thought I'd give the M1 a go before looking into other MIDI controller keyboards. I loved the M1 when I was playing and keen to get it into the mix somehow on this new chapter.

So I fired it up with no expectations really, and to my surprise it powered up no problem and the sounds were there - it was in great shape. I did get the 'low battery' warning though and so proceeded to YT vids to find out procedure for changing it. Followed one of the vids and swapped out the battery and put it all back together. So far so good.

When I tested again on the workbench it appear to be fine. So I powered it down and moved it to my computer area where I planned to use it. But when I powered it back up I ran into an issue. The screen no longer displayed text but only a long yellow/green solid bar across the top line and nothing else (see images below). I also lost the lights on the buttons to the left of the screen and they did not appear to be doing anything.

I've tried to do the factory reset procedure and that has no effect. I have downloaded the sysex app and the sound patches from Korg site, also purchased a MIDI to USB adaptor cable (a quality one) and am all set to go except that there is no way in this state that I can get the M1 to communicate with the computer through MIDI in/out ports. And I don't have the portable cards to plug directly into the M1.

Sorry to be so long in explanation but hopefully the info is useful. If anyone has some ideas about what to try to get this beauty back in business, I'd sure appreciate some advice. Thanks in advance!

Image

Image