Mpc 2000 not booting and screen flashing

The place for parts & services: Modifications, Spare Parts and Repair Services, Sample Packs, Accessories.
Forum rules
This forum follows the same rules outlined in Gear For Sale Rules and Guidelines

Moderators have the right to edit your posts to keep them within the framework of these rules.
Post Reply
Bain
Newbie
Newbie
Posts: 1
Joined: Mon Aug 29, 2016 12:00 am

Mpc 2000 not booting and screen flashing

Post by Bain » Mon Aug 29, 2016 12:12 am

I'm hoping that someone electronically savvy can help me. I was modding my mpc 2000(drum machine from 1997) to include an internal scsi port and all seemed well continuity wise. After I put the motherboard back into the case I connected the psu and the screen to the motherboard to see if it would boot.

When I power on the mpc the screen lights up for .5 second and then shuts off . This happens repeatedly until i turn off the mpc. The psu seems to be turning itself off and restarting which is why the screen doesn't stay on.

I don't know if its my mpc motherboard or a psu issue. I've tested the psu with a multimeter and the values that I am getting are not 12volts or 5volts which I should be getting. The values that I get are just under somewhere around 11.95v and 4.5v, maybe those values are close enough.

When I measure where the psu connects to the motherboard I get a fluctuating power spikes and drops that coincidence with the ticking sound of the psu and the screen flashing. I've inspected ths psu and nothing seems to be burnt out.

Has anyone had this issue before? If so does it sound like a psu issue? Thanks for any help.

Post Reply