Akai MPC500 gets noisy in Record Mode?

Discussions about anything related to samplers and sampling techniques.
Post Reply
Active Member
Active Member
Posts: 355
Joined: Fri Aug 19, 2005 12:47 pm
Location: Marinha Grande, Portugal / Oslo, Norway

Akai MPC500 gets noisy in Record Mode?

Post by paugui » Tue Jun 11, 2013 11:53 pm


I had some time today and decided to try and sample a bit with my Akai MPC500, that I got used some time ago (never tried this feature so far as I didn't have much time, so just sticked to play some sequences with imported samples).

But when I tried to do that today, I noticed that as soon as I get into record mode, there is some hiss coming from the outputs, unless I choose direct monitoring off.

I have tried to change the other settings, but I seem to get this background noise that isn't really dependent on the input volume (can only notice some change for really high volumes).

Is this a normal problem, or is it just me doing something wrong?

Thanks in advance,


User avatar
Posts: 22
Joined: Thu Apr 10, 2008 9:21 am
Real name: Paul
Gear: microKORGs, miniKORG 700s, K Station, Bass Station II, Nova, Ultranova, SH-201, JV-1010, CS-5, DX7IID, TX802, HS-2/E, VZ-1, FZ-1
Location: Rugeley, U.K.

Re: Akai MPC500 gets noisy in Record Mode?

Post by marland » Fri Jul 12, 2013 11:46 am


I had this same issue with an MPC 500 - and unfortunately it is a fault with the Analogue to Digital Converters.
(I ended up selling it as faulty).


Posts: 2
Joined: Tue Oct 29, 2013 8:42 am

Re: Akai MPC500 gets noisy in Record Mode?

Post by Clearsong » Tue Oct 29, 2013 8:53 am

I have an MPC-2500 and I have noticed a hiss when I enter record mode. My samples sound fine when I enter edit mode or start assigning them to pads in program mode. It helps to run your samples through some kind of EQ before they enter your sampler. I usually apply a little EQ from my mixer (Macki 1220i) and that helps to keep them sounding the way I want. If your sampler's hiss is really bothersome and the samples still sound that way when they are used in the sequencer, you might just have a faulty unit.

Post Reply