Page 1 of 1

Gotek and FlashFloppy E34 error

Posted: Sat Jun 30, 2018 10:54 pm
by Mooger5
OK, so I bought a Gotek SFR1M44-U100K USB floppy emulator for the SY77.
It should have been the 720k version, I know, but that was the only model available at the local importer. Seeing that you need to adapt the 26 pins to 34, just like with the 1.44 floppy drives that reportedly work with the SY, I thought I´d give it a shot.

I didn´t use an adapter BTW, having instead desoldered the 34 pin and the power connector and soldering directly the 26 pin cable from the SY to the Gotek´s PCB. I believe I got the connections right, but if someone knows of any shortcomings, please advice.
I also tried different jumper combinations, several thumbdrives, several formats. Nothing worked. Even pressing both buttons at startup for the auto-format feature. It did autoformat the thumbdrive, but the SY kept saying "bad disk".

On the FlashFloppy site it´s said the only difference between the 1.44 model and the 720k Gotek models is in the firmware, and that the FlashFloppy firmware is the same for both models, so I flashed it in according to these instructions:

It´s apparently working as it should, as it even lets me update the firmware via USB thumbdrive only.
But the error E34 keeps appearing :(

Any thoughts?

Re: Gotek and FlashFloppy E34 error

Posted: Mon Jul 02, 2018 6:58 am
by Mooger5 ... r-Messages

So E34 means "No entries to navigate: Direct Navigation mode found no valid directories or image files to display. Add some valid image files to the USB drive."

I´m also missing the initial setup.

" Initial setup has two basic steps:

Set up the physical interface to the host system
Configure the operating mode for image navigation
Physical Interface
By default FlashFloppy will emulate the Shugart floppy interface. This is compatible with a broad range of systems including Amiga, Atari ST, Amstrad CPC, and many other devices. Shugart-compatible systems will typically expect the Gotek to respond as 'unit 0'. Therefore place the selection jumper at location S0 at the rear of the Gotek.

IBM PC compatibles use a slightly modified interface which places the disk-changed signal on a different pin. To select this interface mode place a jumper at location JC at the rear of the Gotek. The host system may expect the Gotek to respond as 'unit 1': in this case place the selection jumper at location S1 at the rear of the Gotek.

An alternative method to specify the interface mode (Shugart or PC) is via the FF.CFG file.

See Host Platforms for detailed instructions and troubleshooting for specific host systems."

So I must place the jumpers at the JC and S1 and configure the OS for PC compatible. The odd part is there seemed to be some consensus the jumpers for the SY77 must be on S0=M0. Anyway, I´ve got a lot to do.

Re: Gotek and FlashFloppy E34 error

Posted: Mon Jul 02, 2018 9:12 pm
by Mooger5
I really could use some help here, folks.

For instance, I can´t find the FF.CFG file. Everytime I put the thumbdrive back in the computer, it comes with a file named IMAGE_A.CFG. Is this the same as the FF.CFG? I take it FF is for FlashFloppy. But that´s about it.
The only time I get 000, 001, 002 etc is when I write some files with the .HFE extension, but the SY77 returns with a Bad Disk message. It would help if the files were in true SY format, but I can´t find any on the net. Is there a way to convert a .syx into a .J01 etc?

I´m going to recheck the connections, maybe I´ve misplaced a wire or two. The Gotek doesn´t need to be linked to a host for the firmware and to be installed, afterall. Just because the new OS is working OK is therefore no guarantee that the Gotek is correctly wired to the SY77. In fact, that may just be the cause of the Bad Disk messages.Fingers crossed.

Re: Gotek and FlashFloppy E34 error

Posted: Mon Jul 02, 2018 9:42 pm
by Mooger5
Found some mismatches. This is the way to connect a 26-pin to a 34 according to the FlashFloppy Wiki.

(26-pin) -> (34-pin + power)
1 -> 5V
2 -> 8
4 -> 10
6 -> 2
7 -> 12
8 -> 34
10 -> 16
12 -> 18
14 -> 20
15 -> GND
16 -> 22
18 -> 24
20 -> 26
22 -> 28
24 -> 30
26 -> 32

Re: Gotek and FlashFloppy E34 error

Posted: Tue Jul 03, 2018 12:49 am
by Mooger5
It WORKS! :mrgreen:

Had to copy the FF.CFG example to the thumbdrive and edit it to 'interface = ibmpc' and put the jumpers on S0 MO for the wire connections posted above.

I saved ALL to the Gotek, then did a factory reset to the SY77 so the Internal bank would be identical to Preset 1, then loaded the file from the Gotek again and it went back to the Internal bankprior to the factory reset.

It works, and it works nicely.

Thanks for your attention.