Manikin Memotron won't boot

Pulling out your hair? Don't know what to do or where to go? Ask in here.
Forum rules
READ: VSE Board-Wide Rules and Guidelines

If your Help request has been solved, please edit your first post in order to select the Image Topic Icon to let others know your topic has been solved.
Post Reply
Posts: 17
Joined: Sat Feb 25, 2017 9:58 pm

Manikin Memotron won't boot

Post by AIDS » Sun Jul 15, 2018 5:56 pm

It's been slow to boot for a while and I'd just kind of got used to waiting a minute or so for it to come round as it was working fine after that.

Now powers up fine but stays at the Memotron v1.3 screen indefinitely, tried the 'hardware reset' a couple of times, left it for a few hours, just stuck there.

Can't say that I've heard of this kind of failure before in a synth.

Please do share any handy ideas as Manikin are utterly shite with their support, in the past they've ignored muliple emails, the last time I had a failure of the voice select pot I managed to get a brief email exchange after calling them and all they could suggest was shipping the whole thing back to them in Germany... to replace a bloody pot.

Then they went dead on me again when I asked if they could advise my regular repair guy or just ship me the part.

As it was that time I managed to persuade my repair guy to have a look, he won't touch anything that he calls a computer in a box ie only does analog but sometimes he'll do random bits if it's something he knows, did a decent job of sapping the pot out.

No way he's gonna touch this - any ideas?

Post Reply