Mc-909 needs help!!

Pulling out your hair? Don't know what to do or where to go? Ask in here.
Forum rules
READ: VSE Board-Wide Rules and Guidelines

If your Help request has been solved, please edit your first post in order to select the Image Topic Icon to let others know your topic has been solved.
Post Reply
rabidhamster
Newbie
Newbie
Posts: 1
Joined: Sat Aug 18, 2018 3:04 am

Mc-909 needs help!!

Post by rabidhamster » Sat Aug 18, 2018 3:18 am

Hi, I picked up a Roland Mc-909 recently that only seems to be partly working. I don't think the sequencer pads or velocity pads are functioning, and while I can get it to sample, and pass through audio while sampling, the only other sound I've been able to get so far is with the twin beam solo synth. Well, it will also make noise for the test mode sound test. I did the factory reset about 9 times, then finally figured out how to make it go into test mode. I don't know if its because I didn't have tempo/mute control selected the times I tried it and it didn't work, or if the system reset helped, but finally.

Well system test goes ok til test 3 - DIMM. It says something like DIMM: NG below it, Read/Write DIMM: NG.

Ok, I think, NG sounds like No Good. I open it up and no Ram stick at all. Slot looks fine. Isn't this thing supposed to work fine with no Ram stick? Or is that where the 16mb it comes with supposed to be as well?
There is also no expansion card installed.

I've been watching tear down and troubleshooting videos on this, but haven't found anything related to my problem exactly , so if anyone has any other ideas any help will be appreciated.

Oh, I should also say i haven't tried triggering this with midi but I could probably sit down and figure out how to make the MPC4000 tell this sucker what to do if I really have to. Have to do some cleaning as I only have room on the desk for one at a time ATM.

Post Reply