Page 1 of 1

Waldorf Q Burning OS for Hours

Posted: Wed Sep 26, 2018 5:54 am
by ElevatedCartographer
A friend of mine was kind enough to lend me her Waldorf Q to use in my studio for awhile. I noticed that it still had OS 1.18 on it and was in need of an update. I tried to update directly to the newest version and it didn't work, just said corrupt OS file on the Q. So I tried again with OS 2.0 and after a couple attempts I was able to get it to start Burning the OS. Now I'm a little freaked out because, it has been updating for almost 4 hours.

Everything I've read says if I turn it off it'll be completely bricked so I'm just sitting here waiting and hoping that it finally finishes the update and reboots. IF anyone has updated the Q or other vintage synths via Midi file and knows how long it is supposed to take it would seriously help me to keep from losing it. Update started at 6PM and it has now just said "Burning OS 2.0" for the last several hours.

Any insight is greatly appreciated, there is really absolutely nothing on the matter anywhere online... which I suppose is good that I haven't found a bunch of bricked Q's...

Re: Waldorf Q Burning OS for Hours

Posted: Wed Sep 26, 2018 1:25 pm
by Rasputin
Updating firmware on a borrowed item... what could possibly go wrong?

Regardless of the wisdom of that decision, I believe there is a fail-safe on the Waldorf Q where you can force it to expect an OS update at boot.

If you run out of ideas, try holding Multimode+Peek with the Waldorf power off, and keep holding it as you turn the power on. Although, it may automatically put itself into "Send OS" mode if it detects a firmware update gone bad anyway.

Try another MIDI interface (preferably something not USB!) or use MIDIOX or Bome SendSX at a slow speed.

Re: Waldorf Q Burning OS for Hours

Posted: Wed Sep 26, 2018 5:03 pm
by ElevatedCartographer
Thanks, Its now been 15 hours and I'm about ready to hit that power... I'll have all the fingers and toes crossed for this one.

Re: Waldorf Q Burning OS for Hours

Posted: Wed Sep 26, 2018 5:41 pm
by ElevatedCartographer
Good news team! I unplugged it from power and gave it a reboot. It did indeed turn back on and as Rasputin suggested it defaulted to requesting an OS Dump as the failed OS Update left it with no OS at all. Please note this was while updating the OS not the Boot OS. I think if I'd corrupted or deleted the boot OS I would be in a very different boat.

FYI it took less than 60 seconds to burn the OS the second time around.