D-50 sounding distorted, noise & creaking

Pulling out your hair? Don't know what to do or where to go? Ask in here.
Forum rules
READ: VSE Board-Wide Rules and Guidelines

If your Help request has been solved, please edit your first post in order to select the Image Topic Icon to let others know your topic has been solved.
gkmaia
Newbie
Newbie
Posts: 20
Joined: Wed Dec 05, 2018 9:02 am

Re: D-50 sounding distorted, noise & creaking

Post by gkmaia » Sat Dec 22, 2018 8:45 pm

Looking at the chorus IC pin table would you know what results to expect on a logic probe?

Image

Mooger5
Expert Member
Expert Member
Posts: 1458
Joined: Tue May 06, 2008 5:11 pm
Location: Lisbon

Re: D-50 sounding distorted, noise & creaking

Post by Mooger5 » Sat Dec 22, 2018 9:19 pm

You have to connect the probe´s red terminal to the +5V line that feeds the chip and the black terminal to ground.
Then, probing around will read either a pulsating LED, or a steady High or Low.
The pulses confirm the data is flowing.
A steady High shall appear at the power line itself and at every pin that is pulled High.
A steady Low shall appear at any ground pin and at every pin that is pulled Low.
If you read a steady signal where there should be a pulse it´s where something is probably not right.

Select TTL, not CMOS.
Herrare umanum est.

gkmaia
Newbie
Newbie
Posts: 20
Joined: Wed Dec 05, 2018 9:02 am

Re: D-50 sounding distorted, noise & creaking

Post by gkmaia » Thu Dec 27, 2018 2:42 am

No luck. Unfortunately. These are the last updates:

- New PCM54 DAC installed
- Chorus IC & Chorus RAM IC removed, checked and cleaned at 20X magnification.
- Checked all traces from-to Chorus and Chorus RAM ICs. And they are all fine. No shorts or fails.
- Chorus IC & Chorus RAM IC welded back and each pin tested for continuity

Still getting the cracking and noise from all patches. But If I edit patches to set chorus balance to 0 it works just fine.

Would you recommend look elsewhere on the PCB to find the issue? Or seems like a definitely have a back Chorus IC?

Bellow goes an image of the block diagram.

Image

Mooger5
Expert Member
Expert Member
Posts: 1458
Joined: Tue May 06, 2008 5:11 pm
Location: Lisbon

Re: D-50 sounding distorted, noise & creaking

Post by Mooger5 » Thu Dec 27, 2018 3:19 pm

Try contacting the seller in the ebay link. Read the description. Maybe the item didn´t sell or the seller still has one available.

Good luck.

viewtopic.php?f=5&t=102457&hilit=crackl ... 45#p806128
Herrare umanum est.

gkmaia
Newbie
Newbie
Posts: 20
Joined: Wed Dec 05, 2018 9:02 am

Re: D-50 sounding distorted, noise & creaking

Post by gkmaia » Thu Dec 27, 2018 9:14 pm

Mooger5 wrote:Try contacting the seller in the ebay link. Read the description. Maybe the item didn´t sell or the seller still has one available.

Good luck.

viewtopic.php?f=5&t=102457&hilit=crackl ... 45#p806128
Thanks Mooger5. I will do that.
I ordered all new RAM ICs as I have seen on another post someone had a issue with one of those chips.

gkmaia
Newbie
Newbie
Posts: 20
Joined: Wed Dec 05, 2018 9:02 am

Re: D-50 sounding distorted, noise & creaking

Post by gkmaia » Thu Dec 27, 2018 9:52 pm

Mooger5 wrote:Try contacting the seller in the ebay link. Read the description. Maybe the item didn´t sell or the seller still has one available.

Good luck.

viewtopic.php?f=5&t=102457&hilit=crackl ... 45#p806128
I am wondering what would happen if I just remove the Chorus chip all together. Will I do any harm to other ICs?
As I was reading on the other post you mentioned the synth, Reverb, Chorus are all independent blocks that flow to the DAC. So removing the Chorus may just eliminate chorus?!? Is that correct?

Mooger5
Expert Member
Expert Member
Posts: 1458
Joined: Tue May 06, 2008 5:11 pm
Location: Lisbon

Re: D-50 sounding distorted, noise & creaking

Post by Mooger5 » Fri Dec 28, 2018 12:13 am

Try it. The only problem I see is the unit not finishing booting up. Other than that, if it still boots up, it won´t hurt anything, I think.

Did you try powering ON while pressing preset nr. 26?
Herrare umanum est.

gkmaia
Newbie
Newbie
Posts: 20
Joined: Wed Dec 05, 2018 9:02 am

Re: D-50 sounding distorted, noise & creaking

Post by gkmaia » Wed Jan 23, 2019 9:32 am

I did manage to create a clean patch by "init" the partials. It sounds clean and perfect.

But as soon as I start messing with chorus look what happens... seems chorus flanger options 3 and 4 are completely busted.


Post Reply