Page 2 of 2

Re: D-50 sounding distorted, noise & creaking

PostPosted: Sat Dec 22, 2018 8:45 pm
by gkmaia
Looking at the chorus IC pin table would you know what results to expect on a logic probe?

Image

Re: D-50 sounding distorted, noise & creaking

PostPosted: Sat Dec 22, 2018 9:19 pm
by Mooger5
You have to connect the probe´s red terminal to the +5V line that feeds the chip and the black terminal to ground.
Then, probing around will read either a pulsating LED, or a steady High or Low.
The pulses confirm the data is flowing.
A steady High shall appear at the power line itself and at every pin that is pulled High.
A steady Low shall appear at any ground pin and at every pin that is pulled Low.
If you read a steady signal where there should be a pulse it´s where something is probably not right.

Select TTL, not CMOS.

Re: D-50 sounding distorted, noise & creaking

PostPosted: Thu Dec 27, 2018 2:42 am
by gkmaia
No luck. Unfortunately. These are the last updates:

- New PCM54 DAC installed
- Chorus IC & Chorus RAM IC removed, checked and cleaned at 20X magnification.
- Checked all traces from-to Chorus and Chorus RAM ICs. And they are all fine. No shorts or fails.
- Chorus IC & Chorus RAM IC welded back and each pin tested for continuity

Still getting the cracking and noise from all patches. But If I edit patches to set chorus balance to 0 it works just fine.

Would you recommend look elsewhere on the PCB to find the issue? Or seems like a definitely have a back Chorus IC?

Bellow goes an image of the block diagram.

Image

Re: D-50 sounding distorted, noise & creaking

PostPosted: Thu Dec 27, 2018 3:19 pm
by Mooger5
Try contacting the seller in the ebay link. Read the description. Maybe the item didn´t sell or the seller still has one available.

Good luck.

viewtopic.php?f=5&t=102457&hilit=crackling&start=45#p806128

Re: D-50 sounding distorted, noise & creaking

PostPosted: Thu Dec 27, 2018 9:14 pm
by gkmaia
Mooger5 wrote:Try contacting the seller in the ebay link. Read the description. Maybe the item didn´t sell or the seller still has one available.

Good luck.

viewtopic.php?f=5&t=102457&hilit=crackling&start=45#p806128


Thanks Mooger5. I will do that.
I ordered all new RAM ICs as I have seen on another post someone had a issue with one of those chips.

Re: D-50 sounding distorted, noise & creaking

PostPosted: Thu Dec 27, 2018 9:52 pm
by gkmaia
Mooger5 wrote:Try contacting the seller in the ebay link. Read the description. Maybe the item didn´t sell or the seller still has one available.

Good luck.

viewtopic.php?f=5&t=102457&hilit=crackling&start=45#p806128


I am wondering what would happen if I just remove the Chorus chip all together. Will I do any harm to other ICs?
As I was reading on the other post you mentioned the synth, Reverb, Chorus are all independent blocks that flow to the DAC. So removing the Chorus may just eliminate chorus?!? Is that correct?

Re: D-50 sounding distorted, noise & creaking

PostPosted: Fri Dec 28, 2018 12:13 am
by Mooger5
Try it. The only problem I see is the unit not finishing booting up. Other than that, if it still boots up, it won´t hurt anything, I think.

Did you try powering ON while pressing preset nr. 26?

Re: D-50 sounding distorted, noise & creaking

PostPosted: Wed Jan 23, 2019 9:32 am
by gkmaia
I did manage to create a clean patch by "init" the partials. It sounds clean and perfect.

But as soon as I start messing with chorus look what happens... seems chorus flanger options 3 and 4 are completely busted.

https://www.youtube.com/watch?v=S5uSXnrHKyE