Page 1 of 2

D-50 sounding distorted, noise & creaking

Posted: Thu Dec 06, 2018 6:10 am
by gkmaia
Hi,

I just toke my D-50 out of storage after 20 years and the sound is completely distorted, noise & creaking.

Software test

- Reverb and Chorus passed
- All buttons and sliders passed
- D/A Adjustment. VR1 on the main board adjusted for minimum distortion done

Hardware - weld

- Touched up all welds on the board. For all ICs and connectors.

Hardware - TPs (mounted test points)

- TP3 D/A out - returns the distorted sound
- TP4 Lower signal - returns distorted sound
- TP5 Upper signal returns distorted sound
- TP1 Lower s/h cont - receiving 4v
- TP2 Upper s/h cont - receiving 4v
- PCM54 - receiving 12V
- 74HC - receiving 5V

I am not sure but seems that according to my TP testing I can eliminate any issues with my bender board, sliders and jacks and the distorted sign happened before those.

Any other means to test it further?

Re: D-50 sounding distorted

Posted: Thu Dec 06, 2018 9:04 pm
by madtheory
The DAC is actually in two parts, a 16 bit DAC and a ladder DAC for the other 4 bits (20 bit in total). You'd need to check the components in the ladder DAC.

Re: D-50 sounding distorted

Posted: Thu Dec 06, 2018 10:14 pm
by Mooger5
Bear in mind the PCM54 is a mono DAC, and is putting out a multiplexed signal to save costs. The distortion you see/hear at TP3 might be normal, as it consists of both Upper and Lower alternating at a very fast rate.
I´ve had a similar problem with my D550 and the culprits were the solder joints on IC13 that had to be reworked.

I believe there should be a +5V pulse signal at TP1 and 2...

Re: D-50 sounding distorted

Posted: Fri Dec 07, 2018 4:28 am
by gkmaia
Mooger5 wrote: I believe there should be a +5V pulse signal at TP1 and 2...
I am getting a +4V on each TP1/2

Re: D-50 sounding distorted

Posted: Fri Dec 07, 2018 4:33 am
by gkmaia
madtheory wrote:The DAC is actually in two parts, a 16 bit DAC and a ladder DAC for the other 4 bits (20 bit in total). You'd need to check the components in the ladder DAC.
IC10 = 16 bit DAC
IC11 = 4 BIT DAC

Any idea how to test these ICs?

Re: D-50 sounding distorted, noise & creaking

Posted: Fri Dec 07, 2018 6:57 pm
by gkmaia
Touched up all welds on the board and same issue.

Ordered a new PCM54 + 74HC ICs and will replace them. Lets see what happens.

In the mean time any other ideas?

Re: D-50 sounding distorted, noise & creaking

Posted: Sat Dec 08, 2018 5:32 pm
by Mooger5
SMD joints too?

I dont have the service notes here atm but testing the chips should be easy. Just follow the input and output lines and watch with a scope or a logic probe the pulse streams. Thats the digital data or 1s and 0s in electric form.
For instance that 74hc chip has four lines going into the resistor network. Theyre the higher 4 bits. If theres 4 pulse trains the chip is most probably ok.

What tests did you run to find tp3 returns a distorted signal?u

Re: D-50 sounding distorted, noise & creaking

Posted: Sun Dec 09, 2018 5:18 am
by gkmaia
Mooger5 wrote:SMD joints too?

I dont have the service notes here atm but testing the chips should be easy. Just follow the input and output lines and watch with a scope or a logic probe the pulse streams. Thats the digital data or 1s and 0s in electric form.
For instance that 74hc chip has four lines going into the resistor network. Theyre the higher 4 bits. If theres 4 pulse trains the chip is most probably ok.

What tests did you run to find tp3 returns a distorted signal?u
I am not that trained in electronics but I will try your tips.

On TP3 I connected a headphone and the output sound distortion was there. Same way the output jack.

Re: D-50 sounding distorted, noise & creaking

Posted: Sun Dec 09, 2018 9:10 pm
by Mooger5
Well, the synth has been in storage for the last 20 years. Did you install a fresh battery and do a reset already?
Have you checked the PSU voltages?
Looked for bad capacitors?

Those routines always come first. We just assume upon reading the OP the obvious stuff is already done.

Be sure to AC couple your phones with a capacitor, before the DC ruins them.

Good luck.

Re: D-50 sounding distorted, noise & creaking

Posted: Sun Dec 09, 2018 9:32 pm
by gkmaia
Mooger5 wrote:Well, the synth has been in storage for the last 20 years. Did you install a fresh battery and do a reset already?
Have you checked the PSU voltages?
Looked for bad capacitors?

Those routines always come first. We just assume upon reading the OP the obvious stuff is already done.

Be sure to AC couple your phones with a capacitor, before the DC ruins them.

Good luck.
PSU voltages are good. Replaced all capacitors on the board yesterday.
All capacitors around the DAC were fine.
There was one faulty near the CPU and was the C50.
I am waiting for my new DAC to arrive to then test everything.

Re: D-50 sounding distorted

Posted: Fri Dec 21, 2018 8:28 am
by gkmaia
madtheory wrote:The DAC is actually in two parts, a 16 bit DAC and a ladder DAC for the other 4 bits (20 bit in total). You'd need to check the components in the ladder DAC.
I may have found the source of my problem but I don't actually know how to pin point it.

If I edit a patch and change the all chorus balances to 00 it sings perfectly.

That is the basic flow of data in the system:

Reverb -> dual 2-4 line decoder -> D/A converters -> Quad bilateral switch -> Filters -> Speakers

Reverb -> Chorus -> SRAM -> Chorus -> Reverb

If I balance chorus to 0 and just use reverb seems that all ICs in the main flow are OK.

But if I turn Chorus ON, then something is going wrong either on Chorus or SRAM.

Have you tested the chorus or the sram ICs signals or outputs?

Re: D-50 sounding distorted, noise & creaking

Posted: Fri Dec 21, 2018 8:41 pm
by Mooger5
Here, a similar problem is described and solved. Hope it helps.

viewtopic.php?f=5&t=78276#p741443

Re: D-50 sounding distorted, noise & creaking

Posted: Sat Dec 22, 2018 6:25 am
by gkmaia
Mooger5 wrote:Here, a similar problem is described and solved. Hope it helps.

viewtopic.php?f=5&t=78276#p741443
Thanks Mooger. I've been following this thread.

I got the reverb and SRAM ICs out of the PCB today. Put it back and did a good check on pads and traces. All 100%.

Just waiting a turned socket for the SRAM chip to arrive. Then I will put it back and test again.

Fingers crossed. If that is not it. Then I will be in trouble.

Re: D-50 sounding distorted, noise & creaking

Posted: Sat Dec 22, 2018 4:34 pm
by Mooger5
What about the chorus chip?

Re: D-50 sounding distorted, noise & creaking

Posted: Sat Dec 22, 2018 7:57 pm
by gkmaia
Mooger5 wrote:What about the chorus chip?
I am not sure yet. Waiting my sram socket to arrive so I can attach it with a socket instead of soldering directly to the PCB.

After that I will turn it on again and test it. But till then just waiting.

It would be good to know more how to test the chorus IC with a probe or similar