Korg polysix ensemble fx not working ....

Pulling out your hair? Don't know what to do or where to go? Ask in here.
Forum rules
READ: VSE Board-Wide Rules and Guidelines

If your Help request has been solved, please edit your first post in order to select the Image Topic Icon to let others know your topic has been solved.
Post Reply
patk20
Newbie
Newbie
Posts: 11
Joined: Thu Feb 28, 2019 5:58 am

Korg polysix ensemble fx not working ....

Post by patk20 » Thu Feb 28, 2019 6:10 am

hi everybody , just bought a korg polysix and got a weird problem .... ensemble fx only work when i select a patch that comes with the fx .... but as soon as you move the effect knob back and forth ... it wont work anymore ??!!
also noticed that the 3 last position of the attenuator knob goes quieter.... i know someone had similar issue on the forum but never told what it was .



edit: just noticed the switch for the wave form act the same way as the ensemble swtich position .... you select a patch with pmw you can increase or decrease intensity but as soon as you put the switch to saw wave and come back to pwm it wont work .... so the 3 selector switches are acting wrong ...

Mooger5
Expert Member
Expert Member
Posts: 1459
Joined: Tue May 06, 2008 5:11 pm
Location: Lisbon

Re: Korg polysix ensemble fx not working ....

Post by Mooger5 » Fri Mar 01, 2019 12:44 am

Probably the Mod switch doesn´t work as well? P13 line interrupted. In what condition is the KLM367 board?
Herrare umanum est.

patk20
Newbie
Newbie
Posts: 11
Joined: Thu Feb 28, 2019 5:58 am

Re: Korg polysix ensemble fx not working ....

Post by patk20 » Fri Mar 01, 2019 12:58 am

was replaced by a brand new one by last owner

Mooger5
Expert Member
Expert Member
Posts: 1459
Joined: Tue May 06, 2008 5:11 pm
Location: Lisbon

Re: Korg polysix ensemble fx not working ....

Post by Mooger5 » Fri Mar 01, 2019 1:04 am

OK. Try resitting the respective connectors.
If it doesn´t fix it, inspect the respective joints and redo them.
Just a sec.
Herrare umanum est.

patk20
Newbie
Newbie
Posts: 11
Joined: Thu Feb 28, 2019 5:58 am

Re: Korg polysix ensemble fx not working ....

Post by patk20 » Fri Mar 01, 2019 1:04 am

wheb you say « line » you mean trace ?

Mooger5
Expert Member
Expert Member
Posts: 1459
Joined: Tue May 06, 2008 5:11 pm
Location: Lisbon

Re: Korg polysix ensemble fx not working ....

Post by Mooger5 » Fri Mar 01, 2019 1:10 am

The P13 line in the KLM367 goes from/to:

- Pin 30 of IC 32
- CN06 pin 10
- CN10 pin 5

IC32 is the processor chip.
CNXX are the cable connectors.

Good luck!
Herrare umanum est.

patk20
Newbie
Newbie
Posts: 11
Joined: Thu Feb 28, 2019 5:58 am

Re: Korg polysix ensemble fx not working ....

Post by patk20 » Fri Mar 01, 2019 1:13 am

ok thx ill check that when im back for work ! thx for your help ;)

Mooger5
Expert Member
Expert Member
Posts: 1459
Joined: Tue May 06, 2008 5:11 pm
Location: Lisbon

Re: Korg polysix ensemble fx not working ....

Post by Mooger5 » Fri Mar 01, 2019 1:16 am

patk20 wrote:wheb you say « line » you mean trace ?
Yes, it´s a signal bus. Travels through PCB traces and the wires connecting other PCBs...

Edit - No problem. Truth is I hate the Polysix´s schematics, but this time it looks like a simple fix. Cheers.
Herrare umanum est.

patk20
Newbie
Newbie
Posts: 11
Joined: Thu Feb 28, 2019 5:58 am

Re: Korg polysix ensemble fx not working ....

Post by patk20 » Fri Mar 01, 2019 11:18 am

just came back and found the problem thx to you !! the cn-06 connector was corroded as h**l !!! cleaned it and plugged it back .... tada all troubles gone !! thx man youre the man !

Mooger5
Expert Member
Expert Member
Posts: 1459
Joined: Tue May 06, 2008 5:11 pm
Location: Lisbon

Re: Korg polysix ensemble fx not working ....

Post by Mooger5 » Fri Mar 01, 2019 11:53 am

Good to hear!
Enjoy the Polysix :)
Herrare umanum est.

Post Reply