Akai AX80 Membranes not Working

Pulling out your hair? Don't know what to do or where to go? Ask in here.
Forum rules
READ: VSE Board-Wide Rules and Guidelines

If your Help request has been solved, please edit your first post in order to select the Image Topic Icon to let others know your topic has been solved.
Post Reply
jayroebuck
Newbie
Newbie
Posts: 2
Joined: Sun Mar 17, 2019 3:08 am

Akai AX80 Membranes not Working

Post by jayroebuck » Sun Mar 17, 2019 3:38 pm

I just purchased an Akai AX80 for $50 from someone who had no idea what it was. It is in good condition except that half of the membrane button do not respond. I know that there is an issue with the solder coming undone on these due to movement, so I opened it up and everything looked remarkably good.
I then hooked up the AX to my Mac through Midi and was able to access every sound that way, so I know that the EPROMS are all working. It looks like it is just the membrane buttons 8 - 32.

Thank for any help.
Last edited by jayroebuck on Mon Mar 18, 2019 8:14 pm, edited 1 time in total.

Online
Rasputin
Active Member
Active Member
Posts: 744
Joined: Thu Jul 21, 2016 4:52 am

Re: Akai AX80 Membranes not Working

Post by Rasputin » Sun Mar 17, 2019 3:50 pm

jayroebuck wrote:I just purchased an Akai AX80 for $50 from someone who had no idea what it was. It is in good condition except that half of the membrane button do not respond. I know that there is an issue with the solder coming undone on these due to movement, so I opened it up and everything looked remarkably good.
I then hooked up the AX to my Mac through Midi and was able to access every sound that way, so I know that the EPROMS are all working. It looks like it is just the membrane buttons 8 - 32.
1) OMG... Incredible deal. Congratulations!

2) This is a super common problem. Don't trust your visual inspection. Desolder the membrane panel "joiner" pins and replace with flexible wire. Problem solved.

3) Replace the factory EPROM with the Tauntek EPROM. Doesn't have anything to do with the membrane buttons, but you should do it anyway, before you get the AX80 all buttoned up again.

jayroebuck
Newbie
Newbie
Posts: 2
Joined: Sun Mar 17, 2019 3:08 am

Re: Akai AX80 Membranes not Working

Post by jayroebuck » Mon Mar 18, 2019 8:14 pm

Thank you! I don't trust my shaky hands enough to do the soldering myself. One or two wires would be fine but this is a lot. I will order the EPROM. I read that it adds SYSEX for all parameters. I would be nice to be able to draw Freq Cutoff in my DAW.

Cheers!

User avatar
Hyde
Junior Member
Junior Member
Posts: 217
Joined: Fri Dec 04, 2015 4:45 pm
Real name: Hyde
Gear: Ensoniq Mirage-EPS-EPS16-ASR10
Ensoniq SQ1-SQ1+
Akai S2000
E-MU ESI2000
Band: When Violets Turn Grey

Re: Akai AX80 Membranes not Working

Post by Hyde » Thu Mar 21, 2019 11:59 am

Rasputin probably knows best. Just as an added fyi, I just fixed both of my Mirage keyboards by disassembling the the keyboard assy, cleaning throughly & reassembling. The mechanical parts of these older machines can create their own issues, if they go unused for a length of time.
Makin' Noises

Post Reply