FIXED - JX8P button issues

Pulling out your hair? Don't know what to do or where to go? Ask in here.
Forum rules
READ: VSE Board-Wide Rules and Guidelines

If your Help request has been solved, please edit your first post in order to select the Image Topic Icon to let others know your topic has been solved.
Post Reply
Tiltrelia
Newbie
Newbie
Posts: 11
Joined: Wed Jul 31, 2019 3:56 am

FIXED - JX8P button issues

Post by Tiltrelia » Wed Jul 31, 2019 4:06 am

So recently I received a Roland JX-8P which was not working, and like many 8P's the level switch was not working, so I bridged the connections and got it working, and put a new CR2030 battery and holder in place while I had the logic board out.

While I was putting the board back into it, the back side made contact with one of the brass standoffs and sparked. After it was put back together the sound coming out is fixed, but several of the buttons on both switch boards were no longer working (they worked before I opened it up). I have confirmed that the buttons themselves are not the problem, so I am thinking one or more of the ICs are fried due to jumping something. Another issues is that it will randomly change what preset that it is set to and try to write it to memory, and these buttons don't work, so something is wrong with it and I can't seem to pinpoint it. any suggestions on where to look for the problem or what IC I may need to replace? Thanks.


Edit:
I took note of what keys were not working and found a trend on the schematic of the switch boards, all but two keys (Cartridge < Memory and Memory > Cartridge) are in the same line. I also believe the short that I talked about was on CN1 which is the main power for the board. Hope this helps.
Last edited by Tiltrelia on Mon Aug 05, 2019 9:42 pm, edited 1 time in total.

Rasputin
Senior Member
Senior Member
Posts: 803
Joined: Thu Jul 21, 2016 4:52 am

Re: JX8P button issues

Post by Rasputin » Wed Jul 31, 2019 5:08 pm

Tiltrelia wrote:
Wed Jul 31, 2019 4:06 am
While I was putting the board back into it, the back side made contact with one of the brass standoffs and sparked.
I'm not sure what part of this repair or reassembly required working on it while powered on, but... :-?

I would probably start by checking the switch matrix driver (IC4 - TC40H245P) or the 10K resistor network connected to it with a logic probe or 'scope.

Tiltrelia
Newbie
Newbie
Posts: 11
Joined: Wed Jul 31, 2019 3:56 am

Re: JX8P button issues

Post by Tiltrelia » Sat Aug 03, 2019 7:23 pm

Thank You so much! I do not have a logic probe on hand but I checked the 10ks which were fine, and I decided to take of IC4 and swap it for IC9 which was for the Memory Cartridge Interface, and the problem went away. Now I will order a new TC40H245P for the cartridge interface as I do have a pair of cartridges for it. Thanks for pointing me in the right direction.

Post Reply