MS2000B Some buttons stopped working

Pulling out your hair? Don't know what to do or where to go? Ask in here.
Forum rules
READ: VSE Board-Wide Rules and Guidelines

If your Help request has been solved, please edit your first post in order to select the Image Topic Icon to let others know your topic has been solved.
Post Reply
DarthVadeanZombie
Newbie
Newbie
Posts: 1
Joined: Tue Nov 12, 2019 2:33 am

MS2000B Some buttons stopped working

Post by DarthVadeanZombie » Tue Nov 12, 2019 2:40 am

I have this korg MS2000B for a few years, I use it live and I take good care of it. Today some buttons stopped working at the same time: "bank 3" , "bank 12", "+Yes" , "Write", "On/off arpegiator" and “octave down” It makes sound and the knobs work just fine. They don't send any MIDI signal too, tested with the MIDI-OX.

Any solution?

Rasputin
Senior Member
Senior Member
Posts: 803
Joined: Thu Jul 21, 2016 4:52 am

Re: MS2000B Some buttons stopped working

Post by Rasputin » Fri Nov 15, 2019 8:43 pm

DarthVadeanZombie wrote:
Tue Nov 12, 2019 2:40 am
Today some buttons stopped working at the same time: "bank 3" , "bank 12", "+Yes" , "Write", "On/off arpegiator" and “octave down”
Can't tell you the exact solution for the MS2000B, but it sounds like one row or column of the key matrix isn't working.

It's very likely that there is an 8-wire connector between the button panel and the mainboard. Check that there is nothing wrong with it.

Also, there is likely a chip (HC138 or similar, probably) which should be driving the key matrix. Test that chip.

Chances are it is one of those two problems. Might be able to tell you more with extremely good pictures of that area of your unit.

Post Reply