M Audio Venom Boot Freeze help please

Pulling out your hair? Don't know what to do or where to go? Ask in here.
Forum rules
READ: VSE Board-Wide Rules and Guidelines

If your Help request has been solved, please edit your first post in order to select the Image Topic Icon to let others know your topic has been solved.
Post Reply
coldwar
Newbie
Newbie
Posts: 33
Joined: Sun Aug 20, 2017 1:13 pm

M Audio Venom Boot Freeze help please

Post by coldwar » Wed Jun 10, 2020 2:46 am

Hi all I have an M Audio Venom synth that is having an issue. It previously worked but now freezes at boot, only displaying VENOM at the bottom of the display with nothing else. It does not respond to any controls or buttons and does not make sound. I have tried several suggestions of new power adapters, soft and hard factory reset, plugging and unplugging a USB cable, and updating the firmware via USB (no go due to the boot freeze). The computer recognized it was plugged in and even loaded the appropriate Venom driver which leads me to believe that the usb controller chip works but is either not communicating with the cpu or just the cpu being frozen either by a bit of damaged code or something physical. When I tested the voltages on the motherboard and else where on the button and knob boards, 3.3 and 5v rails were present and pumping fine. I even tried the DREAM RESET jumper to hopefully just reset the cpu. There are some debug headers on the mobo so I am hopeful that it can be jumpstarted somehow. Just wondering if someone out there had some experience with this machine or have encountered this boot freeze before. I appreciate any help and ideas to help get it going again. Thanks :)

Post Reply