DX Mk1 - dead battery or something else?

Pulling out your hair? Don't know what to do or where to go? Ask in here.
Forum rules
READ: VSE Board-Wide Rules and Guidelines

If your Help request has been solved, please edit your first post in order to select the Image Topic Icon to let others know your topic has been solved.
Post Reply
Goran
Newbie
Newbie
Posts: 1
Joined: Thu Jul 02, 2020 10:38 am

DX Mk1 - dead battery or something else?

Post by Goran » Thu Jul 02, 2020 10:44 am

Hello this is my first post on this forum and i hope someone can help me.

I brought a DX7 home yesterday to test it before I buy it. The keyboard is in wonderful shape (membrane buttons are like new), but it doesn't play a sound - actually some of the presets work funny - either only half of the keyboard produce some kind of sound, or nothing happens until I release the key. The preset names have some invalid characters.

The seller told me that it's because the battery is dying and the presets are corrupted. He loaded it with presets a couple months ago because he had the same problem, and everything worked after that. Then he didn't touch it until I powered it up yesterday, and the presets went corrupted in the meantime. But I checked the battery using the internal function and it looks fine to me - 3.1V. From what I read, that is good voltage and based on that it doesn't need to be replaced.

I scrolled through all the functions, and the function 5 letters also partly look gibberish. Every other function looks normal to me. I also confirmed that MIDI works - it can trigger the sounds in Dexed, although I couldn't make the aftertouch to work (maybe the presets I tried don't support it?)

I sent the internal sounds from DX7 to Dexed via MIDI - every preset name looks corrupted, and none of the presets will produce a sound. This leads me to believe that presets in the DX7 are indeed corrupted. My soundcard doesn't support sysex send so I can't reload the DX7 with the new presets (I'll do it this evening at my friend's studio).

All that said, does it look like a problem with the battery, or it's something else? I appreciate any input you an give me.

Here is the album with photos that I took this morning:

Thank you!!

User avatar
meatballfulton
Moderator
Moderator
Posts: 5939
Joined: Wed Apr 13, 2005 9:29 pm
Gear: Logic Pro X

Re: DX Mk1 - dead battery or something else?

Post by meatballfulton » Thu Jul 02, 2020 11:40 am

My advice is to take it back to the seller and not buy it.
I listened to Hatfield and the North at Rainbow. They were very wonderful and they made my heart a prisoner.

User avatar
Yekuku
Active Member
Active Member
Posts: 665
Joined: Tue Nov 18, 2008 11:29 am
Gear: dk'tronics speech synthesizer :P
Location: Greece

Re: DX Mk1 - dead battery or something else?

Post by Yekuku » Thu Jul 02, 2020 9:12 pm

Hi, it looks like memory corruption.
if restoring to factory defaults does not help, check the power supply.
Also check for battery leakage as this could affect backup memory operation.
I have seen ram chips go bad on the mkI, causing similar issues.
It is all about sharing...

Post Reply