TR-606 Scale & Function Switches Not Working Correctly

Pulling out your hair? Don't know what to do or where to go? Ask in here.
Forum rules
READ: VSE Board-Wide Rules and Guidelines

If your Help request has been solved, please edit your first post in order to select the Image Topic Icon to let others know your topic has been solved.
Post Reply
billybobjoe
Newbie
Newbie
Posts: 17
Joined: Fri Oct 14, 2011 11:13 pm
Real name: Zefan
Gear: Roland JX-3P, D-50, TR-606
Yamaha TX802, RX15, RX17
Ensoniq SQ-80
EDP Wasp, Spider
Akai S2000
Contact:

TR-606 Scale & Function Switches Not Working Correctly

Post by billybobjoe » Wed Sep 30, 2020 5:34 am

Hi all,

I'm hoping to get some advice on my TR-606, which has been acting up recently.

The 606 in question has been well taken care of generally and has no history of fluid spillage and such, but did suffer from some battery leakage and corrosion several years ago that was repaired by a local tech. Some traces had been damaged and were jumpered. Since then I have been using it without batteries without problems.

Problem:

The current problem, which started suddenly last week, has to do with the Scale and Function keys. I'll try to describe the behaviour.

From the user manual:

When running in the PATTERN WRITE Mode, pressing the FUNCTION button (J)
will memorize the SCALE Selector (I) position and virtually display the first step of
each quarter note beat using the 16 LED indicators (L) and allows you to set the last
step by pressing the SELECTOR Switch (K).


The actual behaviour of my unit differs from this in 2 ways:

First, changing the scale selector has no effect. When the function key is held, the LEDs light up on steps 1, 4, 7, 10, 13, and 16, as though set to scale setting 3. This is independent of the actual setting of the scale selector.

Second, it is not possible to set the last step by pressing the selector switches. Doing so has no effect.

The only caveat to this is that sometimes the scale setting will change for 1 bar, before going back to setting 3. This behaviour is highly erratic however, and usually does not occur at all. Testing various settings, I could not figure out any pattern to this occurring.

There is no difference between both internal clock and DinSync modes.

Pattern writing, starting & stopping, switching modes, tempo, drum triggering, etc, all work normally. In fact the unit is completely usable so long as I use 16 step sequences and do not try to sync it with other gear. The problem comes in when I try to sync it, because I can't get it to be on the same time scale as the other machines. It syncs up but can only do an odd triplet sort of rhythm.

I should note as well that this was a sudden failure. I was using the 606 normally, synced with dinsync, and in the middle of the session, the rhythm suddenly got all wonky. I actually have a recording of it you can see here:
It happens at 27:26. The 606 is in the bottom left corner of the frame - you can see the row of red LEDs. I think it happened when I changed instrument... Much attempted resetting and frustration ensues...

Troubleshooting:

I have taken the unit apart and done some inspection. Given the above description I suspected the scale switch may have had a bad connection, or perhaps some corrosion.

Scale Switch
The scale switch itself tests normally in all positions for continuity, and doesn't seem to be shorted, as I initially suspected.

Here is the signal on the pins corresponding to scale 3 with and without it being selected:
Image
Image

Corrosion
Looking at the solder side of the main board, I found some small spots of corrosion in various places. I cleaned this spots up and checked continuity and all the affected traces seem okay. There are several places where small spots of corrosion have eaten through the solder mask, exposing the copper of the trace, but none of these traces show any problems when checked for continuity, and don't appear damaged to the naked eye.

Power Supply
The power rails have the correct voltages, though not perfect. 5V is more like 5.2V and 6V is more like 5.8V. 15V is steady at 14.99V or so, so it's solid. Although, there was some corrosion around the power input components. I have since replaced the main power transistors: Q41 & Q42, as well as the nearby capacitors, as others have had issues with these and there were some signs of previous corrosion in the area. I am using a Boss ACA-120 power adapter.

CPU
The CPU pins are toggling on the scope and the other functions seem okay, so it seems like the CPU is okay.

Logic ICs, RAM, etc.
Reading online about some similar (although not the same) issues and looking at the schematic, I came to suspect the NAND chips (IC3/6) and some of the transistors Q5/6/13, and the RAM chips.

Looking at the NAND chips outputs on the oscilloscope, they seem to be functioning correctly (and not exhibiting analog behaviour like some others reported). Beyond this I'm not sure what to look for.

The RAM seems to be fine, as all pattern writing is normal.

I was looking at Q13, and all the pins seem to be at a fixed voltage, either 5V or just over 4V. I saw on the schematic one pin should be at +B? I couldn't find any explanation of this. I'm not sure what the proper behaviour of this transistor is, but there was some corrosion junk around its pins, so it caught my attention. I have since replaced the transistor, cleaned the area, and replaced the adjacent capacitor.

Next Steps?

Image

Looking at the schematic around the scale switch, there really isn't much going on here. We can also see that several different components / functions share the same CPU pins, time multiplexed, and all those other functions are working normally, so I'm not sure where to go from here.

Here is the pcb near the switch (marked in yellow). The red circles indicate the areas where the solder mask has been corroded but I have tested the continuity to be intact.

Image

Schematics can be found here: http://machines.hyperreal.org/manufactu ... chematics/
See schematic 5 for the scale switch.

The OP of this thread on SOS describes the closest problem I've found to mine on the net so far: https://www.soundonsound.com/forum/view ... 517#314909
The problem eventually turned out to be the NAND gate, IC6 I beleive, which was incorrectly driving the CE/WE signals to the RAM. I checked these signals on the scope just in case and they seem okay. No analog behaviour like the OP saw. Plus pattern writing behaves normally...

Based on this I also checked IC3 (Datasheet) but it seems normal, as noted above. Not 100% sure though...

Any advice or help would be greatly appreciated!

Post Reply