Roland D-10

Pulling out your hair? Don't know what to do or where to go? Ask in here.
Forum rules
READ: VSE Board-Wide Rules and Guidelines

If your Help request has been solved, please edit your first post in order to select the Image Topic Icon to let others know your topic has been solved.
Post Reply
Posts: 4
Joined: Wed Jan 10, 2007 2:40 pm
Location: Columbus, OH

Roland D-10

Post by lochen » Wed Apr 18, 2007 1:19 am

I was playing along on my Roland D-10 and all of a sudden it seemed like it reset itself. But it would keep resetting, so I made sure the power was secure in the outlet. Now all it does is start up and I get no sounds and none of the buttons work to change sounds or navigate, All i can tell that works is the volume slide. Any suggestions?
All I have is an Alesis Micron and a Korg Electribe A mkII and I'm happy :]

User avatar
Junior Member
Junior Member
Posts: 120
Joined: Tue Aug 29, 2006 1:20 am
Gear: Andromeda • Serge • Buchla
Location: Los Angeles

Post by jonkull » Wed Apr 18, 2007 1:26 am

I haven't touched a Roland D10 in 10 years so I can't be specific but there was a design defect in them that would cause one of the chips to unseat itself. That could cause what you're describing. It happened to me a couple times. I'd just pop it open and push the chip back in place. Can't remember which chip it was though. Mine also showed the same symptoms before it completely stopped working altogether. Maybe it's just dead...

User avatar
Junior Member
Junior Member
Posts: 237
Joined: Fri Nov 11, 2005 1:29 pm
Location: Spain. Europe.

Post by DX » Wed Apr 18, 2007 6:31 pm

As said, It seems to be a chip fault, probably the ROM chip. Maybe it is dead, maybe it need to be pressed for hooking to the socket right.

Caution: if you decide to press any IC, ground yourself before doing it. Instant static discharges (high voltage at low amp) can kill your integrated circuits.

I have a D10 for 3 years without any problem (I knock on wood :) )
Roland Promars, E-mu EMAX and some other machines...

Post Reply