Korg EMX-1: some buttons aren't working well anymore...

Pulling out your hair? Don't know what to do or where to go? Ask in here.
Forum rules
READ: VSE Board-Wide Rules and Guidelines

If your Help request has been solved, please edit your first post in order to select the Image Topic Icon to let others know your topic has been solved.
Post Reply
User avatar
killedaway
Supporting Member!
Supporting Member!
Posts: 1030
Joined: Sat Apr 21, 2007 2:22 am
Gear: Electribes x 6
Revolution
Monomachine MKII
microKORG
CS01
& more!
Band: killedaway/allyourblood
Location: California, US

Korg EMX-1: some buttons aren't working well anymore...

Post by killedaway » Tue Dec 18, 2007 12:46 am

i've had my EMX-1 since launch, whenever that was (2003 or so), and i use it almost daily. a couple months ago, i disconnected it and rearranged my studio some; the EMX-1 sat unmessed-with for about 2-3 weeks while i was slowly moving stuff about. up until this point, it has performed flawlessly.

soon after, i had things the way i wanted them; i reinstated the EMX-1 on my keyboard stand and plugged it in. everything internally seems to be working perfectly as always, but now some of the buttons require quite a bit of pressure in order to function. the poorly-circled areas below denote which buttons are having problems.

Image


any ideas what might be causing this? the EMX-1 has never been dropped, or bumped, never had anything spilled on or in it -- basically, it's been babied since the first day i got it. about the only thing i can think of is that while it was stored away, i had it resting on it's "bottom" -- that is, the bottom edge when you're looking at the face of the unit head-on (highlighted in red in the picture)... could this have warped the PCB inside at all? could setting it on its bottom like that have done any other damage?

lastly, i'm considering that it may be some accumulation of dust from worn contacts (carbon, or whatever). i've had this happen to video game controllers and other electronics, and simply wiping the contacts clean of any of this build-up fixed it up perfect. i'm hoping that's it, but figured i'd ask around before taking 'er apart.

any help is greatly appreciated. thanks, gang!
1.5.9.13
1.5.9.13

User avatar
Hosni
Newbie
Newbie
Posts: 31
Joined: Mon Jun 05, 2006 2:12 pm
Location: Finland
Contact:

Re: Korg EMX-1: some buttons aren't working well anymore...

Post by Hosni » Tue Dec 18, 2007 4:18 am

I have the same problem, but only with the step keys from 1 to 16.
I have had my unit since 2004.

I have also looked inside and either I looked the problem from the wrong place, or I ididn't look hard enough because I didn't see anything special in the stepkeys' contactsurfaces. They look identical to the other buttons in the machine.

Maybe I should open it again and use something to clean the contacts anyway.

-HarriL
Korg EMX & ESX, Novation KS, Quasimidi 309, FR Revolution, DSI Evolver
My EMX videos

User avatar
killedaway
Supporting Member!
Supporting Member!
Posts: 1030
Joined: Sat Apr 21, 2007 2:22 am
Gear: Electribes x 6
Revolution
Monomachine MKII
microKORG
CS01
& more!
Band: killedaway/allyourblood
Location: California, US

Post by killedaway » Tue Dec 18, 2007 7:57 am

sorry to hear yours is giving you trouble too! you know, i wouldn't mind this happening half as much if it was something gradual -- like, say, over the course of a year or so. but this is pretty sudden; it went from working 100% to screwy in a few weeks time (if even that).

i've never even seen the guts of an EMX-1, so i'm not sure what's going on with the contacts. i guess i may as well crack 'er open...
1.5.9.13
1.5.9.13

User avatar
Hosni
Newbie
Newbie
Posts: 31
Joined: Mon Jun 05, 2006 2:12 pm
Location: Finland
Contact:

Post by Hosni » Tue Dec 18, 2007 2:27 pm

killedaway wrote:i wouldn't mind this happening half as much if it was something gradual -- like, say, over the course of a year or so. but this is pretty sudden; it went from working 100% to screwy in a few weeks time (if even that).
Oh, i forgot that. In my case it was more like it gradually became harder and harder to press the buttons, over a 8 - 12 month period.

Im glad that all of my my esx's buttons are working like a charm though.


-HarriL
Last edited by Hosni on Wed Dec 19, 2007 12:44 am, edited 1 time in total.
Korg EMX & ESX, Novation KS, Quasimidi 309, FR Revolution, DSI Evolver
My EMX videos

User avatar
killedaway
Supporting Member!
Supporting Member!
Posts: 1030
Joined: Sat Apr 21, 2007 2:22 am
Gear: Electribes x 6
Revolution
Monomachine MKII
microKORG
CS01
& more!
Band: killedaway/allyourblood
Location: California, US

Post by killedaway » Wed Dec 19, 2007 12:42 am

i opened up my EMX today and couldn't find a thing wrong with it. despite the contacts being immaculate, i cleaned them anyway. after reassembly, i didn't notice any significant improvement, so... oh well.
1.5.9.13
1.5.9.13

Mpresev
Junior Member
Junior Member
Posts: 142
Joined: Thu Aug 30, 2007 5:01 pm

Post by Mpresev » Wed Dec 19, 2007 1:52 am

sorry about that..

My Korg MS2000's buttons stopped working.. I had to take it to the shop.. THey said Korg's button is cheaply made.. Whatever..

It cost me 185.00 to fix 7 buttons

Post Reply