JX-8P busted

Pulling out your hair? Don't know what to do or where to go? Ask in here.
Forum rules
READ: VSE Board-Wide Rules and Guidelines

If your Help request has been solved, please edit your first post in order to select the Image Topic Icon to let others know your topic has been solved.
Post Reply
User avatar
fingerbib2000
Newbie
Newbie
Posts: 93
Joined: Wed Aug 16, 2006 12:08 pm

JX-8P busted

Post by fingerbib2000 » Mon Jan 14, 2008 12:47 pm

my JX-8P no longer powers up, i haven't been using it that much, just powering it on and off with all my other synths. I can hear a buzzing like power is going in but there's no life.
Obviously it could be anything, but anyone have an idea what is likely to be the problem, a ballpark figure of how much it would cost and where in NW england I could get it repaired? not much info to give you guys i know but any help would be appreciated!
Sequential Circuits Pro-8, Rolands TB-303, MKS-80, JX-8P, SH-09. Waldorfs Microwave XT, Pulse. Yamahas RS7000, A4000, DX-200. 2 x Cheetah MS-6. Novations Supernova 1 & 2. Korg ER-1. Creamware Pulsar 2.

User avatar
UTEPguy
Newbie
Newbie
Posts: 47
Joined: Tue May 03, 2005 4:43 pm
Location: El Paso & Juaritos
Contact:

Post by UTEPguy » Mon Jan 14, 2008 5:05 pm

Can you post some pics of the inside? The 8p is fairly easy to open up, the only weird part is to remove the screws from the sides. That should give you an idea, the good thing is that the power is a separate board, if you could check that (where the huge transformer is) and verify if something looks burned, leaking, or smells funny and post the pics, I can help you out.
Synth arsenal: Fusion 6HD, JX-8P + pg-800, XP-10, and MS-2000.

User avatar
fingerbib2000
Newbie
Newbie
Posts: 93
Joined: Wed Aug 16, 2006 12:08 pm

Post by fingerbib2000 » Mon Jan 14, 2008 6:07 pm

great. i'll open her up tonight and get some pics for you,
cheers!
Sequential Circuits Pro-8, Rolands TB-303, MKS-80, JX-8P, SH-09. Waldorfs Microwave XT, Pulse. Yamahas RS7000, A4000, DX-200. 2 x Cheetah MS-6. Novations Supernova 1 & 2. Korg ER-1. Creamware Pulsar 2.

User avatar
Mush
Active Member
Active Member
Posts: 503
Joined: Mon Sep 19, 2005 9:06 pm
Gear: I have all the gear I need.
Band: Mush Orchestra / Rasmus Nyåker
Location: Copenhagen Noise Lab, Denmark
Contact:

Post by Mush » Mon Jan 14, 2008 6:18 pm

fingerbib2000 wrote:great. i'll open her up tonight and get some pics for you,
cheers!
That could be some wonderful p**n quote...

User avatar
Maschinengeist
Supporting Member!
Supporting Member!
Posts: 1448
Joined: Sat Jan 21, 2006 3:42 pm
Real name: Steph. J
Gear: Multimeter
Frequency Counter
Oscilloscope
Signal Generator
Logic Probe
and more stuff
Band: Cybernetik
Location: Sherbrooke, Quebec, Canada
Contact:

Post by Maschinengeist » Mon Jan 14, 2008 8:50 pm

Could be a few things:

1) Faulty bridge rectifier
2) Dead capacitors
3) Faulty IC (Voltage regulator)
4) "Leaky" transitor
5) Defective transformer

Your tech should be able to identify the source of the problem quite rapidely.
-------------------------------------------------------------------
MuzikElektronix.com
Music electronics repair & More
Help? See TechZone
Parts? email!
Service Manuals?+/-2000 documents!
Sorry, they aren't free
Now on FACEBOOK: "Muzik Elektronix"

User avatar
fingerbib2000
Newbie
Newbie
Posts: 93
Joined: Wed Aug 16, 2006 12:08 pm

Post by fingerbib2000 » Mon Jan 14, 2008 11:31 pm

thanks for the info, just got to find a reliable tech in my area now..

but here are some xxx pics of the JX, nothing looks broken to my untrained eye, the fuse seems fine and there's no real burning smell, just your regular synth smell...

http://www.minds.may.ie/~lineone/JX-8p/100_0744.JPG

http://www.minds.may.ie/~lineone/JX-8p/100_0745.JPG

http://www.minds.may.ie/~lineone/JX-8p/100_0747.JPG

http://www.minds.may.ie/~lineone/JX-8p/100_0754.JPG

http://www.minds.may.ie/~lineone/JX-8p/100_0756.JPG

http://www.minds.may.ie/~lineone/JX-8p/100_0758.JPG

http://www.minds.may.ie/~lineone/JX-8p/100_0759.JPG

thanks for looking..
Sequential Circuits Pro-8, Rolands TB-303, MKS-80, JX-8P, SH-09. Waldorfs Microwave XT, Pulse. Yamahas RS7000, A4000, DX-200. 2 x Cheetah MS-6. Novations Supernova 1 & 2. Korg ER-1. Creamware Pulsar 2.

User avatar
UTEPguy
Newbie
Newbie
Posts: 47
Joined: Tue May 03, 2005 4:43 pm
Location: El Paso & Juaritos
Contact:

Post by UTEPguy » Tue Jan 15, 2008 11:53 pm

Yep, everything looks ok. Are you taking it to a tech? If you are taking in a couple of days and want to tinker with it, you can just check outrule the powersupply board by sticking a voltmeter were it says ac out.
Synth arsenal: Fusion 6HD, JX-8P + pg-800, XP-10, and MS-2000.

User avatar
fingerbib2000
Newbie
Newbie
Posts: 93
Joined: Wed Aug 16, 2006 12:08 pm

Post by fingerbib2000 » Tue Jan 15, 2008 11:57 pm

UTEPguy wrote:Yep, everything looks ok. Are you taking it to a tech? If you are taking in a couple of days and want to tinker with it, you can just check outrule the powersupply board by sticking a voltmeter were it says ac out.
i know nothing about electronics so thanks for the tip, i'll try that..
Sequential Circuits Pro-8, Rolands TB-303, MKS-80, JX-8P, SH-09. Waldorfs Microwave XT, Pulse. Yamahas RS7000, A4000, DX-200. 2 x Cheetah MS-6. Novations Supernova 1 & 2. Korg ER-1. Creamware Pulsar 2.

User avatar
fingerbib2000
Newbie
Newbie
Posts: 93
Joined: Wed Aug 16, 2006 12:08 pm

Post by fingerbib2000 » Sat Feb 16, 2008 8:44 pm

fingerbib2000 wrote:
UTEPguy wrote:Yep, everything looks ok. Are you taking it to a tech? If you are taking in a couple of days and want to tinker with it, you can just check outrule the powersupply board by sticking a voltmeter were it says ac out.
i know nothing about electronics so thanks for the tip, i'll try that..
bump.

Just opened it again to go at again with multimeter....

but it has come back to life!

love the old 'leave a week, open it and close it again' fix!
Sequential Circuits Pro-8, Rolands TB-303, MKS-80, JX-8P, SH-09. Waldorfs Microwave XT, Pulse. Yamahas RS7000, A4000, DX-200. 2 x Cheetah MS-6. Novations Supernova 1 & 2. Korg ER-1. Creamware Pulsar 2.

User avatar
crystalmsc
Synth Explorer
Synth Explorer
Posts: 2860
Joined: Thu Jul 13, 2006 7:15 am
Gear: uWaveXT,uQ,Pulse+;Ion;MiniBrt,Karma,Mntrb,Volcas,01R;Venom,NordModular,L2X;Evolver;JP8080,MKS70,JD990,D50,MC909,MC80ex,Microcon2;TG77,RS7k,AN200,AN1x
Band: Crystaline
Location: Synth Garden
Contact:

Post by crystalmsc » Sun Feb 17, 2008 4:06 am

fingerbib2000 wrote:love the old 'leave a week, open it and close it again' fix!
:lol: good to hear that..so, may be the problem is within case not properly installed. but anyway the JX did the magic again 8) hope all goes well and it will play well for a long time.
Kaossilatron - Voicillator
http://crystaline.bandcamp.com
Station: Ableton Live 10 Suite, Obscurium, Push 2, Ultranova, MS-20m, Wavedrums

Post Reply