Korg Mono/Poly triggering issue...

Pulling out your hair? Don't know what to do or where to go? Ask in here.
Forum rules
READ: VSE Board-Wide Rules and Guidelines

If your Help request has been solved, please edit your first post in order to select the Image Topic Icon to let others know your topic has been solved.
Post Reply
User avatar
Zonkout
Supporting Member!
Supporting Member!
Posts: 281
Joined: Thu May 04, 2006 7:32 pm
Gear: Salad Shooter, Flowbee, Marsona 1200, Jetta TDI, Original Jams, VCR
Band: Low Red Center
Location: Austin, TX

Korg Mono/Poly triggering issue...

Post by Zonkout » Tue Oct 20, 2009 6:59 am

Anyone have any experience with the Mono/Poly keyboard?
Mine was having triggering problems (some keys not holding the gate open, others not triggering at all), so I pulled out the keyboard, took off the trigger bus board, and rubbed a little electronic contact cleaner under the rubber pads. Now more keys don't trigger correctly than before I cleaned the contacts (oops).
I hadn't seen a trigger system like the one on the Monopoly--what is the best way to fix the triggering issues?
________________________________________
I own some key boards and rhythmic boxes.

bleurgh
Newbie
Newbie
Posts: 79
Joined: Sat Feb 21, 2009 5:54 am

Re: Korg Mono/Poly triggering issue...

Post by bleurgh » Wed Oct 21, 2009 6:05 am

You need to wait a while for the contact cleaner to fully dry. I've done that before with a CR8000 then tried to use the buttons again straight away and they mostly don't work at all, so don't put it all back together until it's fully dried (give it about half an hour just to make sure).

The other thing is that the contacts may have oxidised. I think this can be cured by using a pencil eraser on the contacts.

User avatar
WhinyLittleRunt
Active Member
Active Member
Posts: 480
Joined: Fri May 19, 2006 1:41 am
Location: CT

Re: Korg Mono/Poly triggering issue...

Post by WhinyLittleRunt » Wed Oct 21, 2009 1:41 pm

Use the pencil eraser. You don't even need to use any liquid substance to clean them - the eraser will remove any oxidation and make it work. Also be sure you aligned the rubber pads correctly into the holes otherwise the keys ain't makin it to the contact...
I like vintage synths....

User avatar
Zonkout
Supporting Member!
Supporting Member!
Posts: 281
Joined: Thu May 04, 2006 7:32 pm
Gear: Salad Shooter, Flowbee, Marsona 1200, Jetta TDI, Original Jams, VCR
Band: Low Red Center
Location: Austin, TX

Re: Korg Mono/Poly triggering issue...

Post by Zonkout » Sun Oct 25, 2009 12:28 am

Great tips, thanks. Never thought to try an eraser.
________________________________________
I own some key boards and rhythmic boxes.

Post Reply