JX3P pitch bender not working

Pulling out your hair? Don't know what to do or where to go? Ask in here.
Forum rules
READ: VSE Board-Wide Rules and Guidelines

If your Help request has been solved, please edit your first post in order to select the Image Topic Icon to let others know your topic has been solved.
Post Reply
User avatar
otto
Synth Explorer
Synth Explorer
Posts: 1571
Joined: Thu Nov 10, 2005 8:00 pm
Location: Utah

JX3P pitch bender not working

Post by otto » Sat Dec 19, 2009 6:13 pm

The pitch bender doesn't work. I've opened it up and nothing obvious is wrong, unplugged and re-plugged the connector (LFO button is also connected here and works fine). I'm contemplating re-soldering the connections but beyond that I don't know. I read something about the ability to turn the midi to bender off through a button combination but I would assume that only applied to external midi control over the bender.

The bender appears to control the pot magnetically, something I'm not very familair with...
hello darkness, my old friend
I've come to talk with you again

User avatar
rhino
Supporting Member!
Supporting Member!
Posts: 2607
Joined: Sat Aug 02, 2008 5:00 pm
Real name: bill
Gear: keepers:
Kurzweil K2500x
Ensoniq TS-12
Yamaha SY-99
Alesis QS-8
Roland JD-800
Roland JX-10
Akai AX-80
Ensoniq SQ-80
Korg DSS-1
Moog Mini
Fizmo
Location: kentucky hills

Re: JX3P pitch bender not working

Post by rhino » Sat Dec 19, 2009 8:10 pm

first thing that comes to mind is IC4; a 14051 MUX. next would be IC3; a dual-op amp.

DMM pin 1 of IC4 on the button board while moving the bender... should go from 0v (center) to +5v (either way)

Then scope pin 3 of IC4... should be a pulse-train with one segment rising and falling with the bender notion.

next, scope pin 8 of IC 5 (the op-amp follower) and look for the same type pule there.
When the wise man points to the stars, the fool looks at the finger.
- Confucius

User avatar
otto
Synth Explorer
Synth Explorer
Posts: 1571
Joined: Thu Nov 10, 2005 8:00 pm
Location: Utah

Re: JX3P pitch bender not working

Post by otto » Sun Dec 20, 2009 8:43 pm

Thanks for the info. I'll check it out.
hello darkness, my old friend
I've come to talk with you again

User avatar
otto
Synth Explorer
Synth Explorer
Posts: 1571
Joined: Thu Nov 10, 2005 8:00 pm
Location: Utah

Re: JX3P pitch bender not working

Post by otto » Fri Jan 01, 2010 2:10 am

Ok, I'm not getting anything on pin 1 of IC 4. Will this work:
http://www.mouser.com/ProductDetail/ON- ... ZEi3zmeJIo
hello darkness, my old friend
I've come to talk with you again

User avatar
rhino
Supporting Member!
Supporting Member!
Posts: 2607
Joined: Sat Aug 02, 2008 5:00 pm
Real name: bill
Gear: keepers:
Kurzweil K2500x
Ensoniq TS-12
Yamaha SY-99
Alesis QS-8
Roland JD-800
Roland JX-10
Akai AX-80
Ensoniq SQ-80
Korg DSS-1
Moog Mini
Fizmo
Location: kentucky hills

Re: JX3P pitch bender not working

Post by rhino » Fri Jan 01, 2010 6:43 am

if you get no voltage change on pin 1 og IC 4, the pot might be dead....broken wiper??? it's possible but unlikely that the IC input would short tight to ground.

check the pot: + on one side, -on the other, ground in the center,
DMM pin 6 of IC 3. if voltage goes from - to + wiuth bender motion, then start by changing IC 3.
When the wise man points to the stars, the fool looks at the finger.
- Confucius

User avatar
otto
Synth Explorer
Synth Explorer
Posts: 1571
Joined: Thu Nov 10, 2005 8:00 pm
Location: Utah

Re: JX3P pitch bender not working

Post by otto » Fri Jan 01, 2010 5:46 pm

ok, it appears the pot is working and pin 6 of IC3 does go - to + with bender motion so the likely culprit is IC3?
Thanks again for your help.
hello darkness, my old friend
I've come to talk with you again

User avatar
rhino
Supporting Member!
Supporting Member!
Posts: 2607
Joined: Sat Aug 02, 2008 5:00 pm
Real name: bill
Gear: keepers:
Kurzweil K2500x
Ensoniq TS-12
Yamaha SY-99
Alesis QS-8
Roland JD-800
Roland JX-10
Akai AX-80
Ensoniq SQ-80
Korg DSS-1
Moog Mini
Fizmo
Location: kentucky hills

Re: JX3P pitch bender not working

Post by rhino » Sat Jan 02, 2010 1:09 am

all right.
pin 7 of IC 3 should not smoothly follow the bender, but should 'jump' to -15 or +15.
pin 1 of IC 3 should vary with the bender. if not, replace IC 3
if it DOES, try (again) pin 13 of IC 4. if nothing there, check D 41

as last resort, replace IC 4. The one you posted about is the same internaly, but you need a DIP plastic package.
When the wise man points to the stars, the fool looks at the finger.
- Confucius

tupinamba
Newbie
Newbie
Posts: 3
Joined: Sun Feb 14, 2016 10:56 pm

Re: JX3P pitch bender not working

Post by tupinamba » Tue Jan 16, 2018 4:25 pm

Hi !
Digging up this thread because I'm also trying to fix a non-working bender...

Here is as it goes :
Nothing changes when bending up. But when bending down a few millimeters, it abruptly bends down a lot, then stays this way until bender is down.

I've checked the pot : it seems OK (0 ohm when down, around 82 kohms when up, around 41 kohms when at rest).

I replaced IC3 (4558), IC4 (4051),TR11 (2SK30A) and D41, but problem isn't solved.

On IC3 pin 7, where I should get -15v when pitch bend is down and +15v when pitch bend is up (and I guess around 0v when in its middle position), I get -12v at rest, still -12v when up, and abruptly +14v when moving the pitch bend stick a few millimeters down, and then voltage doesn't change (accordingly to the sound)

IC4 pin 1 stays around 0v when moving bender up or down.

IC4 pin 3 looks like this :

Bender at rest :
Image

Bender up or down :
Image

IC5 pin 8 looks like this :

Bender at rest :
Image

Bender up or down :
Image

If I get it right, the problem is that I should have 0v on IC3 pin 7 when bender is at rest, and -15v or +15v when moving the bender. So the fact that it abruptly goes to +14v seems normal... but it should do so from 0v, not from -12v...

Any clues from the experts?...

Thanks in advance !

tupinamba
Newbie
Newbie
Posts: 3
Joined: Sun Feb 14, 2016 10:56 pm

Re: JX3P pitch bender not working

Post by tupinamba » Wed Jan 17, 2018 9:23 pm

UP... Anyone ?...

Montoya
Newbie
Newbie
Posts: 1
Joined: Tue Jul 02, 2019 10:09 pm

Re: JX3P pitch bender not working

Post by Montoya » Tue Jul 02, 2019 10:17 pm

tupinamba wrote:
Wed Jan 17, 2018 9:23 pm
UP... Anyone ?...
I’m refreshing this thread because I have the same issue, identical symptoms except it’s evident when bending up (instead of when bending down like Tupinamba’s )

After reading the text it seems the obvious chips have been swapped, I would have suspected the cmos chip (4051) as well. I suppose if the cmos chip was blown, and the replacement cmos chip wasn’t handled with care (static discharge is usually what destroys these chips) maybe the 4051 is the issue?

Were you able to sort this out?

Thanks in advance

Post Reply