JUPITER 6 WON'T TURN ON!!

Pulling out your hair? Don't know what to do or where to go? Ask in here.
Forum rules
READ: VSE Board-Wide Rules and Guidelines

If your Help request has been solved, please edit your first post in order to select the Image Topic Icon to let others know your topic has been solved.
Post Reply
TRANSISTOR FACE
Newbie
Newbie
Posts: 37
Joined: Tue Sep 16, 2008 3:16 am
Location: Miami, Florida

JUPITER 6 WON'T TURN ON!!

Post by TRANSISTOR FACE » Wed Jan 20, 2010 3:33 am

Hey guys,

So yeah, my jupiter 6 won't turn on!! It's been working fine for months... I remember this happening a long time ago and it fixing itself in a reasonably short time but I can't help but worry.

What do you guys think the problem might be?

There's just no lights anywhere, not even on that little red rocker switch.

oh man... so worried....

User avatar
V301H
Senior Member
Senior Member
Posts: 764
Joined: Tue Oct 23, 2007 3:58 am
Gear: Fender The Strat, Stratocaster, Jazz Bass Rickenbacker 360-12, 320 Messenger(Mark Farner)
Band: The Characters
Location: New Jersey
Contact:

Re: JUPITER 6 WON'T TURN ON!!

Post by V301H » Wed Jan 20, 2010 3:58 am

Check for blown fuses. If OK check and reseat connecting cables. If it still doesn't work check power supply voltages.
Prophet 5 rev.2, Pro-One, Juno 60, Jupiter 6, Matrix 12, OB8, MS20, Poly 800, CS70M, DX-7, CP35, Casio PX-5S, Hammond C3/M102, Vox Continental/Super Continental, Gibson G101, Farfisa Compact, RMI 300A, Pianet N, Combo Pianet, S770, S760, S50, NS3C

Post Reply