MS-20 mod wheel cable

Pulling out your hair? Don't know what to do or where to go? Ask in here.
Forum rules
READ: VSE Board-Wide Rules and Guidelines

If your Help request has been solved, please edit your first post in order to select the Image Topic Icon to let others know your topic has been solved.
Post Reply
User avatar
otto
Synth Explorer
Synth Explorer
Posts: 1571
Joined: Thu Nov 10, 2005 8:00 pm
Location: Utah

MS-20 mod wheel cable

Post by otto » Thu Feb 18, 2010 3:00 am

So this MS-20 has a loose mod-wheel cable. taking off both side panels it isn't obvious to me where it should plug back in. Any help?
hello darkness, my old friend
I've come to talk with you again

User avatar
Hybrid88
Synth Explorer
Synth Explorer
Posts: 2251
Joined: Sat Jan 17, 2009 8:26 am
Gear: V-Synth, and other stuff...
Location: Australia

Re: MS-20 mod wheel cable

Post by Hybrid88 » Thu Feb 18, 2010 7:54 am

Well, I'm going from memory but I think the cable goes from the left mod wheel area and goes way over to the right somewhere, surely it should be easy enough to find the unused connector that it belongs to?

Most of the Molex connectors connect on the back of the circuit boards and are different sizes so should be easy to match if no others are unconnected.

Oh, just realised - you won't see s#@t from just taking off the side panels, take them off first then the rows of screws on the back (not the ones in the middle, a couple there hold on the transformer ;) ), then the whole top/back should lift off connected only by the cables, then tip it all upside down and there are the boards - much easier to work on, if a bit more work.

User avatar
otto
Synth Explorer
Synth Explorer
Posts: 1571
Joined: Thu Nov 10, 2005 8:00 pm
Location: Utah

Re: MS-20 mod wheel cable

Post by otto » Thu Feb 18, 2010 4:18 pm

Yeah, I can see the boards but I can't see any connectors to plug it into I guess I will have to further dissassemble it as you suggested.
Thanks!
hello darkness, my old friend
I've come to talk with you again

Post Reply