ION Owners? Help with ADSR display?

Pulling out your hair? Don't know what to do or where to go? Ask in here.
Forum rules
READ: VSE Board-Wide Rules and Guidelines

If your Help request has been solved, please edit your first post in order to select the Image Topic Icon to let others know your topic has been solved.
Post Reply
Jaxamillian
Newbie
Newbie
Posts: 37
Joined: Mon Oct 25, 2010 7:02 am

ION Owners? Help with ADSR display?

Post by Jaxamillian » Thu Mar 10, 2011 8:11 pm

It doesn't seem like the ION is displaying the full graphical ADSR info in the LCD when I adjust the Attack, Decay, Sust, Sus time, and release.

The only knobs that seem to change the ADSR display "graph" are sust level, and release, which goes from slanted to a straight line when set to "hold", nothing in between (in regards to release).

Is this correct? If not, what might be the problem? Is there some way to set it back to normal?

Thank you.

Ry-Fi
Supporting Member!
Supporting Member!
Posts: 203
Joined: Thu Jan 31, 2008 9:40 am
Gear: Ion, MKS-30, MKS-50, SQ-1+ 32-voice, TX81Z
Location: Regina, SK
Contact:

Re: ION Owners? Help with ADSR display?

Post by Ry-Fi » Thu Mar 10, 2011 10:03 pm

So only two of the envelope knobs are resulting in a change to the graph on the LCD, and the other 3 aren't? What about the sound? Are all of them affecting the sound, or just the ones that are showing properly on the LCD?

It obviously sounds like there's something very wrong happening, and if you're expecting one of us to say otherwise, you're going to be disappointed... How long have you had this Ion? I'm assuming you're the new owner of one that's apparently defective?

Jaxamillian
Newbie
Newbie
Posts: 37
Joined: Mon Oct 25, 2010 7:02 am

Re: ION Owners? Help with ADSR display?

Post by Jaxamillian » Thu Mar 10, 2011 11:14 pm

The sound is effected normally by all knobs and the number values at the bottom of the screen change accordingly- it's just the graphical line representation that doesn't change.


I've owned it for about 2 months now after buying it used- looking at it, it looks in mint condition, and sounds great. I just wish I could better visualize with a working ADSR graphic.

Any ideas on what may be the problem or how I can reset settings to factory or something?

Ry-Fi
Supporting Member!
Supporting Member!
Posts: 203
Joined: Thu Jan 31, 2008 9:40 am
Gear: Ion, MKS-30, MKS-50, SQ-1+ 32-voice, TX81Z
Location: Regina, SK
Contact:

Re: ION Owners? Help with ADSR display?

Post by Ry-Fi » Fri Mar 11, 2011 3:25 am

Ah, well that sounds a little more promising then. The most important thing is that the envelope settings are audibly correct, and the fact that the numerical values are showing up correctly is even better! Strange about the display graph not working properly though. That's definitely the first time I've heard of this issue!

What OS version are you running? Turn it off, hold Panel Active A and Panel Active D and turn it on. The newest is 1.06, so make sure you're running that. I don't believe there's a way to do a factory reset on the Ion; the equivalent would be flashing the OS and loading the factory patches (available at the Alesis website).

There's a diagnostic mode for the Ion: Turn it off, hold Page < and Page > and turn it on. I'm not sure if there's anything in here that will help, but it's worth checking out and making sure that everything is functioning within parameters.

Honestly, I have a hunch you've got an old OS and are due for an update. I know that older versions have bugs, and 1.06 is almost perfect. Let's hope that this is something strange that can be fixed with an update!

Good luck :thumbright:

Jaxamillian
Newbie
Newbie
Posts: 37
Joined: Mon Oct 25, 2010 7:02 am

Re: ION Owners? Help with ADSR display?

Post by Jaxamillian » Fri Mar 11, 2011 4:46 am

Running boot code: ver. 1.00, and OS code ver. 1.06.

Sigh, well at least, as you said, the audio is working fine. It's just one of those weird annoying things that nags at you. Hopefully it'll magically fix itself some time. =)

User avatar
Stab Frenzy
Moderator
Moderator
Posts: 9723
Joined: Tue Jun 06, 2006 5:41 pm
Gear: Eurorack, RYTM, Ultranova, many FX
Location: monster island*
Contact:

Re: ION Owners? Help with ADSR display?

Post by Stab Frenzy » Fri Mar 11, 2011 5:12 am

I'd reload the OS anyway, it might fix it.

User avatar
Big Gnome
Active Member
Active Member
Posts: 411
Joined: Fri Aug 04, 2006 3:14 am
Gear: E-mu Proteus 2500
Ensoniq ESQ-1
Ensoniq VFX
SCI Prelude
Waldorf Blofeld
Band: The Nondescript
Location: Oakland, CA
Contact:

Re: ION Owners? Help with ADSR display?

Post by Big Gnome » Fri Mar 11, 2011 5:12 am

The Ion doesn't display A, D, and R times proportionally--it graphically shows you the sustain level and each other step's slope and time in ms, and nothing else to the best of my knowledge.
"Sure that's fine in practice, but what about in theory?"
Some of my c**p

Ry-Fi
Supporting Member!
Supporting Member!
Posts: 203
Joined: Thu Jan 31, 2008 9:40 am
Gear: Ion, MKS-30, MKS-50, SQ-1+ 32-voice, TX81Z
Location: Regina, SK
Contact:

Re: ION Owners? Help with ADSR display?

Post by Ry-Fi » Fri Mar 11, 2011 5:39 am

:facepalm: Yup, exactly. I don't know who deserves this more, me or the OP, but we're both very guilty of being dumbasses.

Jaxamillian, curse you for leading me down the path of believing there was a problem in the first place. Me, I started with the assumption that there was a problem and then didn't readjust my perspective once the new evidence was presented. :oops:

Jax, the ADSR graph only exists to show the Sustain level, and the slopes (linear, exp or log) of the other segments: Attack, Decay and Release. The actual proportional times are NOT displayed in the graph. That's what those little numbers are for.

Move along people, nothing to see here.... :?

Jaxamillian
Newbie
Newbie
Posts: 37
Joined: Mon Oct 25, 2010 7:02 am

Re: ION Owners? Help with ADSR display?

Post by Jaxamillian » Fri Mar 11, 2011 6:33 am

Right...you all passed the test...


..
:oops: :oops:

Ry-Fi
Supporting Member!
Supporting Member!
Posts: 203
Joined: Thu Jan 31, 2008 9:40 am
Gear: Ion, MKS-30, MKS-50, SQ-1+ 32-voice, TX81Z
Location: Regina, SK
Contact:

Re: ION Owners? Help with ADSR display?

Post by Ry-Fi » Fri Mar 11, 2011 6:49 am

:lol: Nice try...

Post Reply