Sequential Circuits Split 8 freezing!

Pulling out your hair? Don't know what to do or where to go? Ask in here.
Forum rules
READ: VSE Board-Wide Rules and Guidelines

If your Help request has been solved, please edit your first post in order to select the Image Topic Icon to let others know your topic has been solved.
Post Reply
User avatar
ryryoftokyo
Active Member
Active Member
Posts: 650
Joined: Sat May 05, 2007 1:19 am
Real name: Ryan
Gear: Metal, plastic, wood, and electricity.
Band: Tarot Sync
Location: Massachusetts, USA
Contact:

Sequential Circuits Split 8 freezing!

Post by ryryoftokyo » Sun Mar 27, 2011 5:10 pm

My SCI split 8 is freezing during boot up...it will sometimes make it to "8" when booting up then freezes. The "link" and "preset" button stays lit and nothing responds and the LCD goes blank. What on earth is this?
MU Modular (Moog, Dotcom, STG, Analog Systems, and Moon modules), MS20 (x2), Microbrute, Electribes (EA-1, EMX), microKorg, AN1x, Nord Lead 2x, Blofeld, Alpha Juno 2, DX7, JX8P, Poly 61 (x2), Split 8, TR-505, Monotron Delay, Ace Tone FR-3, Paia Fatman

User avatar
splitpoint
Newbie
Newbie
Posts: 63
Joined: Sat Sep 09, 2006 4:24 pm
Location: Pennsylvania
Contact:

Re: Sequential Circuits Split 8 freezing!

Post by splitpoint » Sun Mar 27, 2011 10:42 pm

It's been more than 20 years since I've had a split-8 but I had an problem similar to yours caused by a grounding issue.

Good luck!
Waveframe 1000, Wavestation, OBMX, EIII, Red Square, esq1, and others...

Post Reply