dead microkorg

Pulling out your hair? Don't know what to do or where to go? Ask in here.
Forum rules
READ: VSE Board-Wide Rules and Guidelines

If your Help request has been solved, please edit your first post in order to select the Image Topic Icon to let others know your topic has been solved.

Re: dead microkorg

Postby man-009 » Thu Apr 12, 2012 3:45 am

the end...good luck all with your dead synths.
man-009
Supporting Member!
Supporting Member!
 
Posts: 398
Joined: Sat Jun 20, 2009 11:54 pm
Band: Man-009

Re: dead microkorg

Postby die monster die » Sun Apr 15, 2012 7:59 pm

I'm having the exact same issue with a MS2000. Very similar to microkorg's power supply.
Voltage regulator S8520F33 and fuse CCP2E20 are dead.
It might depend on the country but you can order them from Korg.
Prices i had here (France) were:
S-8520F33MC = 5,85 €
CCP2E20 = 1,5 €

The regulator feeds the CPU, it might be allright, but i afraid the CPU is dead too.
MS10, Monopoly, Synare S3X, Microkorg, DDD1, Prodigy, UpOne, MFB502, Mopho.
User avatar
die monster die
Newbie
Newbie
 
Posts: 31
Joined: Wed Oct 19, 2005 7:26 pm
Location: France
Real name: Pierre
Gear: MS10, Monopoly, Synare S3X, Microkorg, DDD1, Prodigy, UpOne, MFB502, Mopho.

Re: dead microkorg

Postby man-009 » Mon Apr 16, 2012 3:58 pm

good luck!.. i have a new prob. There are two diodes that could have blown out in my AC adpter path. Mine only works with batteries. I wonder if you can hardwire the adapter wires to the battery leads for power? It's all 9v right?
man-009
Supporting Member!
Supporting Member!
 
Posts: 398
Joined: Sat Jun 20, 2009 11:54 pm
Band: Man-009

Re: dead microkorg

Postby man-009 » Wed Apr 18, 2012 3:07 am

not going to risk the bypass..
man-009
Supporting Member!
Supporting Member!
 
Posts: 398
Joined: Sat Jun 20, 2009 11:54 pm
Band: Man-009

Re: dead microkorg

Postby die monster die » Mon Apr 30, 2012 11:15 pm

Power section is now in working condition.
The LCD screen says "Chck Sum Error". I have no idea what this means.
No mention in the owner or service manual. I believe something else fried.
User avatar
die monster die
Newbie
Newbie
 
Posts: 31
Joined: Wed Oct 19, 2005 7:26 pm
Location: France
Real name: Pierre
Gear: MS10, Monopoly, Synare S3X, Microkorg, DDD1, Prodigy, UpOne, MFB502, Mopho.

Re: dead microkorg

Postby Stab Frenzy » Tue May 01, 2012 3:42 am

Google checksum to see what it means, it'll be easier than me explaining it here. Basically checksum error means that the OS has become corrupted and the synth realises it and so is not attempting to run it. Not sure what course of action to take to fix it, but it's quite likely that the synth is now only good for parts.
User avatar
Stab Frenzy
Moderator
Moderator
 
Posts: 9723
Joined: Tue Jun 06, 2006 5:41 pm
Location: monster island*
Gear: Eurorack, RYTM, Ultranova, many FX

Re: dead microkorg

Postby rcon303 » Mon Feb 20, 2017 1:17 am

hi and i thank everrone in this thread for the info on fixing my dead microkorg.. i bought the needed parts off ebay from china, and i had to buy 5 of each part..l . needless to say after grtting it fixed i have 4 each of the 2 parts needed. if anyone in vermont,new hampshire, massachusetts,usa ,etc needs these parts i can meet you and more kess give em to ya for a cup of coffee or a beer ..
the 2. parts are the S-8520F33MC-BNST2G regulator and the 3 volt ic XC61CN3002MR(the 3pin one).i do not use paypal otherwise id offer these to any non local fellow korgies that need them ...
:guitar: :guitar: :dancer: :dancer:
rcon303
Newbie
Newbie
 
Posts: 1
Joined: Mon Feb 20, 2017 1:06 am

Re: dead microkorg

Postby Stab Frenzy » Wed May 17, 2017 4:41 am

Just a note here in case anyone comes across this because they can't find the now obsolete S-8520F33MC voltage regulator, I found an equivalent part with the same footprint. It's the Ricoh R1223N332H-TR-FE just replaced one in a Microkorg here and it's now successfully delivering 3.3V on the digital line.
User avatar
Stab Frenzy
Moderator
Moderator
 
Posts: 9723
Joined: Tue Jun 06, 2006 5:41 pm
Location: monster island*
Gear: Eurorack, RYTM, Ultranova, many FX

Re: dead microkorg

Postby craigsc » Sat Sep 30, 2017 7:41 pm

Looking for a little help from one of the folks who recently fixed there micro kong. My Son's micro korg does not power up at all. He had let a buddy borrow and I'm guessing he using the wrong power supply. Can someone walk me through the repair in a little more detail than is here in this string? I'm have a DMM and a good soldering iron (and a micro miniature repair specialist at work as well) and I do restore and sell vintage HiFi equipment so I think I could handle just can't figure out what folks are doing exactly. Thanks!
craigsc
Newbie
Newbie
 
Posts: 1
Joined: Sat Sep 30, 2017 7:35 pm

Re: dead microkorg

Postby Asp102 » Thu Jan 04, 2018 10:20 pm

I appreciate this is a long shot, asking 5 years after it’s been posted... but I’m hoping adhmzaiusz might be able to answer a question for me :)

I’ve got a friend’s microkorg board infrobt of me and looks like the EMI filter has gone (continuity on all legs)
You mentioned about bridging this - just curious as to which tracks you bridged. I guess I could trial and error it but some help would be amazing! :)

Thanks so much for all the posts everyone - really helpful :)

*edit*
Don’t worry! I took out the broken EMI filter, tried bridging it the way I assumed it would go and success! A working microkorg!! :D thanks adhmzaiusz - wherever you may be. 5 years on and you’re still shooting troubles! :)
Asp102
Newbie
Newbie
 
Posts: 1
Joined: Thu Jan 04, 2018 10:11 pm

Previous

Return to HELP!

Who is online

Users browsing this forum: No registered users and 16 guests