Korg Monopoly - No Sound

Pulling out your hair? Don't know what to do or where to go? Ask in here.
Forum rules
READ: VSE Board-Wide Rules and Guidelines

If your Help request has been solved, please edit your first post in order to select the Image Topic Icon to let others know your topic has been solved.
Post Reply
changeofeyes
Newbie
Newbie
Posts: 95
Joined: Wed Dec 24, 2008 6:44 pm
Gear: Moog Voyager, Emulator II, Drumulator, Elektron Analog Four, TR-707, Juno-106, MC-808, Microbrute, Yamaha TQ5.
Location: upstate NY

Korg Monopoly - No Sound

Post by changeofeyes » Tue Aug 20, 2013 2:00 am

I'm about to pick up a Korg Monopoly with custom case for $200. The owner had it for 30 years, he said it powers up but doesnt produce sound. Does anyone know what the issue might be? If it's common or fixable?

User avatar
rhino
Supporting Member!
Supporting Member!
Posts: 2607
Joined: Sat Aug 02, 2008 5:00 pm
Real name: bill
Gear: keepers:
Kurzweil K2500x
Ensoniq TS-12
Yamaha SY-99
Alesis QS-8
Roland JD-800
Roland JX-10
Akai AX-80
Ensoniq SQ-80
Korg DSS-1
Moog Mini
Fizmo
Location: kentucky hills

Re: Korg Monopoly - No Sound

Post by rhino » Tue Aug 20, 2013 4:58 pm

For $200, you can't go wrong !! (IMHO). Take it to a good tech and spend $400-500 on repairs and you'll still come out ahead.

Too many posibilities to do much good via text.

1) Power supply (esp. op-amp rails)
2) Broken/corroded output jack (Does headphone out work?)
3) Dead volume pot.
4) Mice/idiots at work inside.
5) Dead VCF
6) Dead VCA
When the wise man points to the stars, the fool looks at the finger.
- Confucius

Post Reply