Roland Tr-909 Strange issue

Pulling out your hair? Don't know what to do or where to go? Ask in here.
Forum rules
READ: VSE Board-Wide Rules and Guidelines

If your Help request has been solved, please edit your first post in order to select the Image Topic Icon to let others know your topic has been solved.
Post Reply
cutoffres
Junior Member
Junior Member
Posts: 153
Joined: Fri May 15, 2009 2:24 pm
Location: Europe

Roland Tr-909 Strange issue

Post by cutoffres » Wed Oct 09, 2013 11:21 am

HI,
i'm repairing a TR909. Evrything is now ok except :

Even if the pattern is erased, There is always a LowTomand and a HIHat at the first step of pattern 1; pattern 3; pattern 5; pattern 7; pattern 9; pattern 11; pattern 13; pattern 15 (so every odd number)


I've replaced eprom : no success

-Maybe a switch scanning problem ? as the technical manual indicate: "... in basic opération , the cpu scans panel switches, store switch outputs, and generates trigger (TRIG) and volume (ACCENT) data for the voice generators..."

-A cpu problem ? (i doubt)

-A Ram problem ?

service maunal is here: http://privat.bahnhof.se/wb447909/dinsy ... TR-909.pdf

Any help is welcome.

Thank you

AK79
Newbie
Newbie
Posts: 22
Joined: Thu Oct 24, 2013 7:12 pm
Gear: RolandSH09, RolandSH2, Korg PS6, Korg700S, SolinaStringEnsemble, MFOS SoundLabUltimate, YamahaDX7, YamahaCS01,SielOpera6, Korg Mono/Poly,OberheimOB8
Location: Hamburg, Germany

Re: Roland Tr-909 Strange issue

Post by AK79 » Thu Oct 24, 2013 7:58 pm

Hi there,
never seen that but I would suspect the RAM because neither the CPU or the switch Matrix could produce a failure that is limited to odd numbered patterns.

cheers
Arne

Post Reply