SQ80 screen and buttons freezing

Pulling out your hair? Don't know what to do or where to go? Ask in here.
Forum rules
READ: VSE Board-Wide Rules and Guidelines

If your Help request has been solved, please edit your first post in order to select the Image Topic Icon to let others know your topic has been solved.
Post Reply
User avatar
dustinh
Active Member
Active Member
Posts: 283
Joined: Tue Jan 04, 2011 7:57 pm
Gear: juno-1, ensoniq sq-80, dsi mopho, microbrute, gretsch guitars, motu 2408, monotron, and caffeine
Location: Seattle, WA

SQ80 screen and buttons freezing

Post by dustinh » Sun Mar 02, 2014 7:25 pm

My beloved SQ80 started acting up recently. I noticed it started to happen after I was using it one day and the power went out and came back on. It was plugged in to a really good power conditioner at the time so I wouldn't think that significant damage was done to the board. The problem may have just coincidentally started around the same time.

Anyway, I turn it on, everything works just fine for a while. Sometimes it takes a couple hours, sometimes only a few minutes, but eventually the screen looks like this.

Image

The picture is blurry, but it's two of the characters from the patch screen. I think they are the actual characters that belong there, but the screen always shows just 2 characters at different points on the screen and they are always above and below each other just like this. The patch that was loaded still plays, the mod wheel and pitch bend still resdponds, but no other buttons respond nor does the data slider. When I turn off and turn back on, everything is fine again until it will eventually repeat the same problem.

I've searched the forums here and elsewhere. I've found similar problems to this but not quite the same problem. The two suggestions I've found so far are the possibility of blown fuses inside or trying a hard reset. I've already tried a soft reset with no success. I'm inclined to think (and I'm hoping) that it's a software issue and not a hardware issue. If it were the fuses, wouldn't the problem be present as soon as I turned the board on as opposed to just occurring randomly?

How risky is doing a hard reset? I don't know a whole lot about electronics so I wouldn't want to damage the board permanently, but I think I should be able to do it as long as I take my time and carefully identify the right components to short.
Last edited by dustinh on Mon Nov 03, 2014 12:54 am, edited 1 time in total.

User avatar
rhino
Supporting Member!
Supporting Member!
Posts: 2610
Joined: Sat Aug 02, 2008 5:00 pm
Real name: bill
Gear: keepers:
Kurzweil K2500x
Ensoniq TS-12
Yamaha SY-99
Alesis QS-8
Roland JD-800
Roland JX-10
Akai AX-80
Ensoniq SQ-80
Korg DSS-1
Moog Mini
Fizmo
Location: kentucky hills

Re: SQ80 screen and buttons freezing

Post by rhino » Mon Mar 03, 2014 3:48 am

First thing I'd try is cleaning BOTH ends of BOTH the 4-wire cable from the display board to the main board and the 5-wire cable from the power supply to the display.
If no joy...
1) need to check the DUART chip - use cooling spray and see if the display comes back.
2) Remove the display/button board and try the cooling spray on the 6500 CPU chip

After that, it gets shitty. Let us know.
When the wise man points to the stars, the fool looks at the finger.
- Confucius

User avatar
dustinh
Active Member
Active Member
Posts: 283
Joined: Tue Jan 04, 2011 7:57 pm
Gear: juno-1, ensoniq sq-80, dsi mopho, microbrute, gretsch guitars, motu 2408, monotron, and caffeine
Location: Seattle, WA

Re: SQ80 screen and buttons freezing

Post by dustinh » Mon Mar 03, 2014 4:39 am

I was hoping you'd respond to this thread as I saw a thread from a while back where you seemed to know your stuff concerning the SQ80, so thanks.

I will try what you suggested in the next few days when I have a chance to take a stab at it and let you know what happens.

User avatar
Jabberwalky
Synth Explorer
Synth Explorer
Posts: 2152
Joined: Fri Apr 01, 2005 6:03 pm
Gear: A hybrid of vintage and modern junk
Band: Variar
Location: Pgh, PA
Contact:

Re: SQ80 screen and buttons freezing

Post by Jabberwalky » Tue Mar 04, 2014 12:18 am

Rhino is the ensoniq godfather around here.

User avatar
dustinh
Active Member
Active Member
Posts: 283
Joined: Tue Jan 04, 2011 7:57 pm
Gear: juno-1, ensoniq sq-80, dsi mopho, microbrute, gretsch guitars, motu 2408, monotron, and caffeine
Location: Seattle, WA

Re: SQ80 screen and buttons freezing

Post by dustinh » Sun Nov 02, 2014 9:09 pm

Well, this has taken me way too long to get to, but I'm finally working through the steps you suggested, rhino. As soon as I opened it up, it was clear that it hadn't been opened in some time. Lots of dust and hair inside. I gave everything a thorough cleaning and started out by cleaning the ends of both the 4 and 5 pin connectors and wires. After doing that, I've had the board turned on for nearly 2 hours now and so far the screen is not freezing yet. I'll let you know if it does.

User avatar
dustinh
Active Member
Active Member
Posts: 283
Joined: Tue Jan 04, 2011 7:57 pm
Gear: juno-1, ensoniq sq-80, dsi mopho, microbrute, gretsch guitars, motu 2408, monotron, and caffeine
Location: Seattle, WA

Re: SQ80 screen and buttons freezing

Post by dustinh » Mon Nov 03, 2014 12:55 am

And an update. I've had the synth on all day and played with it quite a bit. It still hasn't frozen. It's never gone this long without freezing so I think it's fixed. Thanks again rhino for the help!

Post Reply