My Jupiter 6 seems like its dying..

Pulling out your hair? Don't know what to do or where to go? Ask in here.
Forum rules
READ: VSE Board-Wide Rules and Guidelines

If your Help request has been solved, please edit your first post in order to select the Image Topic Icon to let others know your topic has been solved.
Post Reply
User avatar
sqweebking
Junior Member
Junior Member
Posts: 196
Joined: Thu Sep 17, 2009 1:54 am
Gear: Roland, Moog, Yamaha, Korg, Novation, etc.
Band: sqweebking
Location: Maryland

My Jupiter 6 seems like its dying..

Post by sqweebking » Wed May 14, 2014 3:54 pm

So I bought this Jupiter 6 w/ Europa mod on Ebay a while back and it has never been quite right. When I first got it one of the sliders was broken and all the others were scratchy so values would jump around a lot. I recently rebuilt all the sliders and replaced the one broken one. Now that they're all working great the rest of the board is not. Here's what I mean by that:

Occasionally when I turn the board on, it will not go through the typical boot sequence. The patch lights don't light in sequence and the front panel doesn't come on. Nothing really happens and no sound comes from the board. Ill turn it off, wait a few seconds and turn it back on, most times it will boot normally and plays fine for a while. Then the LFO 1 rate light starts going crazy, flashing at random speeds/brightness all the while strange sounds come from the output and all inputs are ignored (panel changes, key presses, etc.) I've also noticed that when the board is otherwise working normally and I turn on the arpeggio things start acting up again. The arpeggio rate is either too fast or unstable (the light does not match the rate at which notes are sounding, rate changes on its own) When I had the front panel apart to rebuild the sliders I also cleaned the pots so the Rate pot is working okay but whatever component it controls seems unresponsive.

What I have checked so far:
All the troubleshooting points provided during the Europa installation
No obvious shorts due to unsoldering/soldering of the CPU socket
Power rails are all within spec and stable
Connectors have all been re seated

To me it seems the CPU is causing this weird behavior as the board is pretty uncontrollable while acting up. No panel controls work, patch changes don't work, key presses don't do anything. The only thing that will stop it is turning the board off, waiting a few seconds and turning it back on. Even then it seems once it gets into the cycle of f**k up it will only work for a few seconds before needing to be power cycled again. Any pointers are greatly appreciated, this thing is driving me crazy.

Post Reply