Page 1 of 1

TR-707 Power Supply Issue

Posted: Tue May 20, 2014 3:29 pm
by emerse
Hey guys,

I recently purchased a TR-707 and am trying to bring it back to life.

I would really appreciate some assistance with identifying the suspected issue with the power supply circuit.

I have the original wall wart power supply (negative tip) 12volt 200ma which is giving a reading of 17.8 volt without load, so I'm assuming this is working correctly.

I have already replaced the power jack on my 707 because the connection was originally loose, however unfortunately it wasn't that simple to get the 707 running properly again.

From studying the schematic I believe I should be getting a reading of -10v at the anode of D2 and +5v at the output of IC1, however I'm getting a +2.6v at both these points?

Furthermore if I take a measurement of the voltage directly from the power input jack. When the device is switched off it gives a reading of 17.8 volts, which is the same as the reading from the tip of the wallwart psu. However when I switch the 707 on, the voltage drops to around 5.5v.

One last bit of information that might help you identify what going on is, the TR 707 has temporarily turned on for approximately 30 seconds on a couple separate occasions and then it just switches off. Today I managed to monitor the voltage whilst it was temporarily on, the voltage dropped from 17.8v when switch off, to 11.7v for 5 seconds when the device was on, then to 5.5v where it stays and the device is obviously off.

Hope this makes sense to someone and you can help me make some progress on my repair :)

I'm really enjoying learning about repairing vintage synthesisers and drum machines, but please bare with me as my knowledge is fairly limited. However I did an introduction to electronics during my sound engineering course, so I do have some basic knowledge on circuits and electronic components.

Thanks in advance.

Jay

Re: TR-707 Power Supply Issue

Posted: Thu May 22, 2014 3:30 am
by intrancewetrust
did you happen to buy it from a guy in north perth?

Re: TR-707 Power Supply Issue

Posted: Sun May 25, 2014 2:40 am
by emerse
nope I bought from a guy in QLD, I'm pretty sure i've isolated the problem to T1. the DC to DC - 10v converter. now i just need to find a replacement :)

any suggestions would be a awesome.

Cheers,
J

Re: TR-707 Power Supply Issue

Posted: Sat Oct 08, 2016 6:14 pm
by TG1
Did you ever get this sorted out? I have a 707 with the same issue

Re: TR-707 Power Supply Issue

Posted: Sun Oct 09, 2016 5:44 pm
by garranimal
emerse wrote: I have the original wall wart power supply (negative tip) 12volt 200ma which is giving a reading of 17.8 volt without load, so I'm assuming this is working correctly.
Wrong. With no load, it should be around 12v.

Re: TR-707 Power Supply Issue

Posted: Mon Oct 10, 2016 1:29 am
by TG1
My PSU actually measures 17.8V unloaded as well, which I read was normal elsewhere, even though the supply is rated for 12V.

Does anyone have a functioning 707 & power supply that they could check?