Yamaha DX7 buttons not responding???

Pulling out your hair? Don't know what to do or where to go? Ask in here.
Forum rules
READ: VSE Board-Wide Rules and Guidelines

If your Help request has been solved, please edit your first post in order to select the Image Topic Icon to let others know your topic has been solved.
Post Reply
rehab
Newbie
Newbie
Posts: 5
Joined: Tue Dec 16, 2014 4:31 pm

Yamaha DX7 buttons not responding???

Post by rehab » Tue Dec 16, 2014 4:33 pm

Hello,

I've just recently acquired an old Yamaha DX7 (mk1) keyboard and have been having some issues.

When I first powered it on, none of the sounds would play and the screen said that the battery needed replaced. I also noticed that all the buttons seemed to work other than the 4 buttons in the bottom Memory Select row.

I replaced the battery with one that i purchased from syntaur. I clipped the leads from the original dead battery and soldered the new battery onto the clipped leads.

Powered the DX7 on and the battery message was no longer present and the sounds played fine.

Issue I'm still having is that the bottom row of 4 buttons under Memory Select are still not responding. So all i'm able to do is play the sounds that are off the DX7 data ram cartridge (that came with) but I'm unable to get to any other functions.

Any ideas as to why the whole Memory Select row of buttons would not be responding?


Thanks,

Mike

commodorejohn
Synth Explorer
Synth Explorer
Posts: 1588
Joined: Mon Aug 12, 2013 2:39 am
Real name: John
Gear: Roland JX-10/SH-09/MT-32/D-50, Yamaha DX7-II/V50/TX7/TG33/FB-01, Korg MS-20 Mini/ARP Odyssey/DW-8000/X5DR, Ensoniq SQ-80, Oberheim SEM
Location: Sacramento, CA
Contact:

Re: Yamaha DX7 buttons not responding???

Post by commodorejohn » Tue Dec 16, 2014 7:50 pm

Since it's only four buttons, I doubt it's an issue with the decoder matrix (I can't find a schematic for it in the service manual, but with as many buttons as there are on the DX7, a non-functional row should probably have a lot more buttons out of commission.) So I'd bet that the switches are just worn out. Luckily, they're pretty easy to replace if you have basic soldering/desoldering skills. The service manual lists it with Yamaha's internal part number KA905510; you can get them for $0.72 apiece here, or order functional equivalents for $0.40 apiece here (at that price, as long as you're in there you may as well replace the whole set - with the price breaks it'll run you about $10.)
Computers: Amiga 1200, DEC VAXStation 4000/60, DEC MicroPDP-11/73

rehab
Newbie
Newbie
Posts: 5
Joined: Tue Dec 16, 2014 4:31 pm

Re: Yamaha DX7 buttons not responding???

Post by rehab » Wed Dec 17, 2014 7:11 am

Thanks for the link to purchase replacements! Will be looking into this since it is so cheap.

So do u think it's just a coincidence that it happens to be those 4 bottom buttons that are all worn out? Just seems weird to me is all.

commodorejohn
Synth Explorer
Synth Explorer
Posts: 1588
Joined: Mon Aug 12, 2013 2:39 am
Real name: John
Gear: Roland JX-10/SH-09/MT-32/D-50, Yamaha DX7-II/V50/TX7/TG33/FB-01, Korg MS-20 Mini/ARP Odyssey/DW-8000/X5DR, Ensoniq SQ-80, Oberheim SEM
Location: Sacramento, CA
Contact:

Re: Yamaha DX7 buttons not responding???

Post by commodorejohn » Wed Dec 17, 2014 7:42 am

It does seem a little odd, and if I could find a diagram for the matrix that shows which buttons are aligned on which rows I could say for sure whether it was possibly a bad connection on one of the row selects. But I can't, and as I said, I doubt there's only four buttons to a row (usually it's eight, so's to fit neatly in a byte-width I/O port.)
Computers: Amiga 1200, DEC VAXStation 4000/60, DEC MicroPDP-11/73

rehab
Newbie
Newbie
Posts: 5
Joined: Tue Dec 16, 2014 4:31 pm

Re: Yamaha DX7 buttons not responding???

Post by rehab » Wed Dec 17, 2014 8:44 am

Image

The bottom right 4 buttons are the only buttons not working. PSW37 PSW38 PSW39 & PSW40

User avatar
Bitexion
Synth Explorer
Synth Explorer
Posts: 4230
Joined: Fri Apr 15, 2005 7:43 pm
Gear: Alesis Andromeda A6
Roland D-50
Creamware Minimax
Yamaha DX7s
Analogue Systems modular
Ensoniq SQ-80
Waldorf Blofeld
Location: Drammen, Norway

Re: Yamaha DX7 buttons not responding???

Post by Bitexion » Wed Dec 17, 2014 1:10 pm

Well, if those 4 buttons were the most used buttons (maybe previous owner only used 4 presets), then it's quite natural for them to break first. Imagine the amount of presses they have endured since 1984.

User avatar
synthroom
Senior Member
Senior Member
Posts: 876
Joined: Sat Sep 08, 2012 3:16 pm
Real name: Kirk
Gear: Fairlight IIx(!), JP-8, D-50, S-50+550, S-760, JX-3P, JD-800, EII, Emax II, Mini, ARP 2600, P-5 Rev.1, Pro-One, Performer, K1m, K5m, few other things.
Location: pdx
Contact:

Re: Yamaha DX7 buttons not responding???

Post by synthroom » Thu Dec 18, 2014 10:14 pm

commodorejohn wrote:It does seem a little odd, and if I could find a diagram for the matrix that shows which buttons are aligned on which rows I could say for sure whether it was possibly a bad connection on one of the row selects.
Yeah, check and see if there is power coming into that set of buttons. It's most likely something upstream from all those buttons that they share.
Fairlight IIx (Mid-Life Crisis - cheaper than a Corvette!)
Roland JP-8, D-50, S-50, S-550(2x), S-760(2x), JX-3P, JD-800
EII, Emax II, Minimoog, ARP 2600, P-5 Rev.1 (broken...), Pro-One, Crumar Performer, K1m, K5m, MS-2000B, Virus KC, a few other things.

User avatar
Synthetech
Junior Member
Junior Member
Posts: 185
Joined: Sun Oct 07, 2012 4:28 pm

Re: Yamaha DX7 buttons not responding???

Post by Synthetech » Fri Dec 19, 2014 1:14 am

Are you sure the row of 4 switches above them work?

They are the other 4 switches out if the usual group of 8 using the same select line signal as the one you are having problems with.

Here's a link to schematics to see:

http://homepages.abdn.ac.uk/mth192/page ... ircuit.pdf

I suspect a problem with either C2 or C3 connectors... on either end. (From board to board)

If you have a scope, check for the pulse signal coming in on C2's red wires.
I HIGHLY SUSPECT YOUR PROBLEM IS ONE OF THESE RED WIRES... or a bad solder connection on that board that is on a trace with a connection to one of those red wires.
Using a DMM Meter's beeping continuity tester will help narrow down the problem

If they check OK, then check for return signals on C3's white, green, um.. "SB"? and pink wires when you press the switches.

rehab
Newbie
Newbie
Posts: 5
Joined: Tue Dec 16, 2014 4:31 pm

Re: Yamaha DX7 buttons not responding???

Post by rehab » Fri Dec 19, 2014 3:52 am

Synthetech wrote:Are you sure the row of 4 switches above them work?

They are the other 4 switches out if the usual group of 8 using the same select line signal as the one you are having problems with.

Here's a link to schematics to see:

http://homepages.abdn.ac.uk/mth192/page ... ircuit.pdf

I suspect a problem with either C2 or C3 connectors... on either end. (From board to board)

If you have a scope, check for the pulse signal coming in on C2's red wires.
I HIGHLY SUSPECT YOUR PROBLEM IS ONE OF THESE RED WIRES... or a bad solder connection on that board that is on a trace with a connection to one of those red wires.
Using a DMM Meter's beeping continuity tester will help narrow down the problem

If they check OK, then check for return signals on C3's white, green, um.. "SB"? and pink wires when you press the switches.
Yes, all of the 4 buttons on the top work. I will try ur suggestion when I get home from work tonight. Thank you for the help. I appreciate it

User avatar
pflosi
Synth Explorer
Synth Explorer
Posts: 3620
Joined: Tue Nov 13, 2007 6:14 pm
Gear: more than 150 characters...
Location: zürich
Contact:

Re: Yamaha DX7 buttons not responding???

Post by pflosi » Fri Dec 19, 2014 10:59 am

Are you sure they're not doing anything? The "internal" will do nothing since most likely you're in the internal preset bank anyways; the "cartridge" will also not do anything if you do not have a cartridge inserted. The "edit" and "function" buttons should get you to a further menu though...

rehab
Newbie
Newbie
Posts: 5
Joined: Tue Dec 16, 2014 4:31 pm

Re: Yamaha DX7 buttons not responding???

Post by rehab » Fri Dec 19, 2014 1:26 pm

I am absolutely sure that none of the bottom right 4 buttons work. The "edit" & "function" buttons do not work at all. None of the memory select buttons work (4)

User avatar
pflosi
Synth Explorer
Synth Explorer
Posts: 3620
Joined: Tue Nov 13, 2007 6:14 pm
Gear: more than 150 characters...
Location: zürich
Contact:

Re: Yamaha DX7 buttons not responding???

Post by pflosi » Fri Dec 19, 2014 1:54 pm

Cool, just wanted to make sure that we can exclude user error. :thumbright:

Post Reply