Roland Juno 60 Minerva Midi Mod Installation Problems

Pulling out your hair? Don't know what to do or where to go? Ask in here.
Forum rules
READ: VSE Board-Wide Rules and Guidelines

If your Help request has been solved, please edit your first post in order to select the Image Topic Icon to let others know your topic has been solved.
Post Reply
ChuckFalcon
Newbie
Newbie
Posts: 57
Joined: Fri Jun 27, 2014 3:24 am
Real name: Chuck Falcon
Gear: Roland Promars MRS-2
Vox Continental
Mellotron M4000D
Roland Juno 60
Moog Theremini
Roland Juno 106
Akai MPC 1000
Band: Chuck Falcon

Roland Juno 60 Minerva Midi Mod Installation Problems

Post by ChuckFalcon » Mon Jan 19, 2015 10:51 pm

Hi everyone! I am the proud owner of a big fat Roland Juno 60 and I love it. I love it so much I wanted to give it midi. Like many others I ordered the Minerva Midi Mod. I started to install the Minerva yesterday and I ran into a some confusion and maybe someone could help who has already installed it.

OK, the installation directions are here: http://kovariant.d250.hu/images/midi..._mod_guide.pdf

I completed steps 1-20 with no problem and then step 21 is where I don't know what to do.

"21. Unplug the 4-pole connector. With a flat screwdriver force the metal plate of the second pin and take it out." I did that successfully (pic 1)!
Image

"21.....At the now free place put the middle wire from Minerva." The only wires from the Minerva that aren't plugged into something already, is a 2-prong connector. What "middle wire" is he talking about, and do I insert that middle wire in the terminal that I just pulled the white one from (pics 2 and 3)?
Image

Image

"22. There is a 2-pole connector with one wire already plugged from Minerva. My 2-pole connector that came in my kit already had 2 wires in it, not 1 (pic 1). What's up with that? What do I do with it?

"22....Put the previously removed wire at the free place of the 2-pole connector." Does this mean the white wire that I pulled in step #21 ? If so, how do I fit it into a 2-prong terminal if both terminals are filled.

I have emailed Laszlo, but I haven't heard anything back yet. I am just very antsy and exited to use this baby. If anyone could shed some light on this situation I would be very grateful.

CHEERS!

Post Reply