Ensoniq SD1 issue

Pulling out your hair? Don't know what to do or where to go? Ask in here.
Forum rules
READ: VSE Board-Wide Rules and Guidelines

If your Help request has been solved, please edit your first post in order to select the Image Topic Icon to let others know your topic has been solved.
Post Reply
alfadawg01
Junior Member
Junior Member
Posts: 103
Joined: Thu Jun 30, 2005 7:14 pm
Gear: Ensoniq SD1, Alesis Ion, iPad2 running Animoog, Galileo Organ, iM1 and Mellotronics M3000HD
Band: The Journey Worship Band
Location: St. Louis, Missouri, USA
Contact:

Ensoniq SD1 issue

Post by alfadawg01 » Sat May 30, 2015 6:50 pm

Hi all,

My Ensoniq SD1 (21-voice, OS 3.0) developed a serious problem after a power surge incident at a recent gig. When I strike a key the note played is very loud and has maximum vibrato. This occurs with internal sounds as well as outgoing MIDI data. When I hold down the footswitch (which is set to provide sustain) the same thing occurs...however when I release the key, the volume drops and the vibrato disappears. I've also discovered that in Preset mode, if I disable pressure (aftertouch), everything sounds normal.

I have reinitialized the SD1 and done the hard reset. Neither of those operations affects the problem.

Based on this, I'm suspecting that the aftertouch system was fried and needs repair. Any thoughts? Is this repairable or is there at least a workaround that would work when individual patches are played? Would upgrading to the OS 4.10 software and chipset cure things or does this seem to be a strictly keyboard problem?

Thanks in advance for your help.

Post Reply