korg poly-61 not responding to pushbuttons

Pulling out your hair? Don't know what to do or where to go? Ask in here.
Forum rules
READ: VSE Board-Wide Rules and Guidelines

If your Help request has been solved, please edit your first post in order to select the Image Topic Icon to let others know your topic has been solved.

korg poly-61 not responding to pushbuttons

Postby crafter57 » Sun Apr 17, 2016 2:03 am

Hi Folks, I replaced all the tact switches on the board as some were not working properly.
it worked fine for awhile but now the assigner board and programmer boards switches are unresponsive, the displays constantly shows program P5 / parameter 61 kinda strange..and won't respond to any pushbuttons. The PSU +15/-15/+5 volt rails are good. Both programmer & assigner boards have voltage, checked all transistors and diodes and are good on both.

Has anyone seen this type of problem before? I doubt both processors have gone suddenly bad
Looking at the prints, I can't seem to find whats common to both boards?

is there a re-boot sequence?
any ideas?
crafter57
Newbie
Newbie
 
Posts: 59
Joined: Tue Aug 25, 2015 2:13 pm

Re: korg poly-61 not responding to pushbuttons

Postby sergios » Sun Apr 17, 2016 3:19 pm

Did you change anything before it stopped working?
Looking for a drone? Beginner pilot? Spark might be your best choice. This is a [url=Mavic Air vs Spark
]comparison between DJI Spark and Mavic Air[/url], check it out.
sergios
Newbie
Newbie
 
Posts: 2
Joined: Thu Feb 18, 2016 12:42 am

Re: korg poly-61 not responding to pushbuttons

Postby garranimal » Sun Apr 17, 2016 5:00 pm

Check the molex connectors for oxidation or breakage. Common problem with the battery corrosion issue for the Poly-61 and Polysix.
User avatar
garranimal
Synth Explorer
Synth Explorer
 
Posts: 1728
Joined: Mon Sep 27, 2004 8:57 pm
Location: USA

Re: korg poly-61 not responding to pushbuttons

Postby Jabberwalky » Sun Apr 17, 2016 5:13 pm

Mine does the reset occasionally, which I need to fix at some point. I'm almost certain there's a corroded power connector going to the cpu board. Jiggling that wire makes it reset. Could be something similar.
User avatar
Jabberwalky
Synth Explorer
Synth Explorer
 
Posts: 2109
Joined: Fri Apr 01, 2005 6:03 pm
Location: Pgh, PA
Gear: Eps16 | An1x | Minikorg700s | Monologue | Maxikorg | Bs2 | Ultranova | Dw8k | Poly61 | Paia9700s | Circuit | PreenFM2
Band: VARIAR

Re: korg poly-61 not responding to pushbuttons

Postby crafter57 » Mon Apr 18, 2016 7:28 pm

Hi guys, yeah after posting this I did alot of searching on this problem where it just hangs on "PS-61", it looks like a bad connector or wire connection somewhere or perhaps the tape sw could be dirty. The battery was previouly changed to a coin cell and the cct board is clean around the battery area. I've been in and out of the synth since I've re-built the end-caps in real wood and tact sw replacement. I will double re-check all connections again. I was loosing my mind on this...
crafter57
Newbie
Newbie
 
Posts: 59
Joined: Tue Aug 25, 2015 2:13 pm

Re: korg poly-61 not responding to pushbuttons

Postby crafter57 » Wed Apr 20, 2016 1:36 am

Well after checking every strand of wire and every JST connector for continuity, they all check out good. I'm still hanging on "PS-61", to boot those darn schematics are really bad to make out. I also cleaned the slider sw in the back but even disconnecting the jack board its still the same issue.. You guys have any other ideas?

its sad how it went from functioning to crippled without knowing why
I'm trying to stay sane..
crafter57
Newbie
Newbie
 
Posts: 59
Joined: Tue Aug 25, 2015 2:13 pm

Re: korg poly-61 not responding to pushbuttons

Postby orys » Sun Jun 03, 2018 11:51 am

Hey there!

Have the same problem although mine was purchased as damaged and seems to be stuck on P5-61 and won't respond to any pushbuttons.
Had battery corrosion but i managed to clean everything and have measured the CPU board which seems to work fine.
I measured all the molex connectors everywhere on all the boards and none seems to be faulty.
So what next?
Did you manage to resurrect yours?

Cheers
Tio
orys
Newbie
Newbie
 
Posts: 12
Joined: Thu Mar 22, 2018 6:25 pm

Re: korg poly-61 not responding to pushbuttons

Postby crafter57 » Wed Jun 20, 2018 8:30 am

Yes, I did resolve this issue which was a disintegrated trace due to the battery acid leakage.
Do you have a voltmeter to check continuity?
crafter57
Newbie
Newbie
 
Posts: 59
Joined: Tue Aug 25, 2015 2:13 pm

Re: korg poly-61 not responding to pushbuttons

Postby orys » Wed Jun 20, 2018 8:44 am

Yes i measured continuity and it seems to have no problem.
Could it be the ROM?
orys
Newbie
Newbie
 
Posts: 12
Joined: Thu Mar 22, 2018 6:25 pm

Re: korg poly-61 not responding to pushbuttons

Postby crafter57 » Wed Jun 20, 2018 9:13 am

check continuity between pin4 of the two MCU's
crafter57
Newbie
Newbie
 
Posts: 59
Joined: Tue Aug 25, 2015 2:13 pm

Re: korg poly-61 not responding to pushbuttons

Postby orys » Wed Jun 20, 2018 9:16 am

MCU's???
What are these?
orys
Newbie
Newbie
 
Posts: 12
Joined: Thu Mar 22, 2018 6:25 pm

Re: korg poly-61 not responding to pushbuttons

Postby crafter57 » Wed Jun 20, 2018 10:25 am

A microcontroller (MCU for microcontroller unit, or UC for μ-controller) is a small computer on a single integrated circuit. ... A microcontroller contains one or more CPUs (processor cores) along with memory and programmable input/output peripherals.

So, IC1 and IC30 are your two MCU's
crafter57
Newbie
Newbie
 
Posts: 59
Joined: Tue Aug 25, 2015 2:13 pm

Re: korg poly-61 not responding to pushbuttons

Postby orys » Wed Jun 20, 2018 10:30 am

Thanks for the info my friend.
I'll check it today and let you know!
orys
Newbie
Newbie
 
Posts: 12
Joined: Thu Mar 22, 2018 6:25 pm

Re: korg poly-61 not responding to pushbuttons

Postby orys » Mon Jul 02, 2018 5:47 pm

Hi there!

Sorry for the late reply but i was really busy at work and didn't get a chance to check the two MCUs you suggested.
I didn't quite figure out which are pins no.4 on each MCU but anyhow from left right, up down there isn't continuity except if I've made every measurement wrong.
Care to tell me which pins to measure please?

Thanks
Tio

This is the actual photo of the problematic board.
Image
orys
Newbie
Newbie
 
Posts: 12
Joined: Thu Mar 22, 2018 6:25 pm

Re: korg poly-61 not responding to pushbuttons

Postby Mooger5 » Mon Jul 02, 2018 8:37 pm

Lots of damaged traces and components on that board. You could try a thorough repair to yours, but it will take lots of time, patience, and dependant on your experience and skills.There are cloned boards for sale if you search around. The price is not inviting at first look, but it comes populated with new components.
Herrare umanum est.
Mooger5
Expert Member
Expert Member
 
Posts: 1280
Joined: Tue May 06, 2008 5:11 pm
Location: Lisbon

Next

Return to HELP!

Who is online

Users browsing this forum: No registered users and 11 guests