korg poly-61 not responding to pushbuttons

Pulling out your hair? Don't know what to do or where to go? Ask in here.
Forum rules
READ: VSE Board-Wide Rules and Guidelines

If your Help request has been solved, please edit your first post in order to select the Image Topic Icon to let others know your topic has been solved.

Re: korg poly-61 not responding to pushbuttons

Postby orys » Mon Jul 02, 2018 8:43 pm

Which components are damaged.
I fixed it already.
Not sure if it's fixed but i found a broken trace and fixed it so it now plays but need to test further.
Will try to load the default presets and see how it goes.
orys
Newbie
Newbie
 
Posts: 12
Joined: Thu Mar 22, 2018 6:25 pm

Re: korg poly-61 not responding to pushbuttons

Postby Mooger5 » Mon Jul 02, 2018 9:21 pm

Well yeah, "lots" is my way of putting everything in the same basket. IC10, 11 and 12 appear quite corroded.
There is definitely a good number of damaged traces around the battery.
Herrare umanum est.
Mooger5
Expert Member
Expert Member
 
Posts: 1196
Joined: Tue May 06, 2008 5:11 pm
Location: Lisbon

Re: korg poly-61 not responding to pushbuttons

Postby orys » Mon Jul 02, 2018 9:59 pm

I've loaded all the factory presets and it seems that all functions work so far.
Need to sort the keybed as there are keys missing and some keys don't work.
I'll report soon with new findings but it seems to be working fine.
The ICs that look like that is because i used some type of acid to clean the corrosion and i washed the board twice in a dishwasher to clean it up perfectly.
orys
Newbie
Newbie
 
Posts: 12
Joined: Thu Mar 22, 2018 6:25 pm

Re: korg poly-61 not responding to pushbuttons

Postby crafter57 » Tue Jul 03, 2018 8:13 am

Ok, so both MCU's have a notch(indent) on the left side of the chip and pin1 starts on the bottom row left, so count 4 pins from the bottom left and check continuity on both MCUs from pin4 to pin4. I do see some traces that could possible be a problem, but lets get thru the initial problem of Hanging on PS-61.
crafter57
Newbie
Newbie
 
Posts: 59
Joined: Tue Aug 25, 2015 2:13 pm

Re: korg poly-61 not responding to pushbuttons

Postby orys » Tue Jul 03, 2018 8:28 am

crafter57 wrote:Ok, so both MCU's have a notch(indent) on the left side of the chip and pin1 starts on the bottom row left, so count 4 pins from the bottom left and check continuity on both MCUs from pin4 to pin4. I do see some traces that could possible be a problem, but lets get thru the initial problem of Hanging on PS-61.


I traced a broken line and i fixed it.
It works fine now but some of the keys are missing and some are not working.
I am cleaning them right as we speak.
I already fixed a PolySix so i'm pretty sure i'll sort the keys too.
Just need to find some and the rubbers that go underneath as some are torn apart.
It seems to be in tune too.
orys
Newbie
Newbie
 
Posts: 12
Joined: Thu Mar 22, 2018 6:25 pm

Re: korg poly-61 not responding to pushbuttons

Postby crafter57 » Wed Jul 04, 2018 7:10 pm

Good that you found the broken trace, that's the usual problem when the battery leaks. Hope you find a solution for the contact strips, btw, don't get those carbon discs and glue them as I've not had success with those. try to find replacement rubber contact strips instead. good luck
crafter57
Newbie
Newbie
 
Posts: 59
Joined: Tue Aug 25, 2015 2:13 pm

Re: korg poly-61 not responding to pushbuttons

Postby orys » Wed Jul 04, 2018 7:51 pm

I'm sticking plastic pieces on the actual keys to make them press lower.
The prices they charge for contact strips are ridiculous.
orys
Newbie
Newbie
 
Posts: 12
Joined: Thu Mar 22, 2018 6:25 pm

Re: korg poly-61 not responding to pushbuttons

Postby crafter57 » Thu Jul 05, 2018 4:01 am

I'm not sure you would get a good contact if the conductive coating has worn off, guess you'll have to try it.
crafter57
Newbie
Newbie
 
Posts: 59
Joined: Tue Aug 25, 2015 2:13 pm

Re: korg poly-61 not responding to pushbuttons

Postby orys » Thu Jul 05, 2018 5:22 am

They work but i have to press hard on some of them.
orys
Newbie
Newbie
 
Posts: 12
Joined: Thu Mar 22, 2018 6:25 pm

Previous

Return to HELP!

Who is online

Users browsing this forum: No registered users and 10 guests