Korg DW8000 not working, please help.

Pulling out your hair? Don't know what to do or where to go? Ask in here.
Forum rules
READ: VSE Board-Wide Rules and Guidelines

If your Help request has been solved, please edit your first post in order to select the Image Topic Icon to let others know your topic has been solved.
HappyFunTimes
Newbie
Newbie
Posts: 75
Joined: Sat May 09, 2015 8:17 pm

Korg DW8000 not working, please help.

Post by HappyFunTimes » Mon Sep 12, 2016 2:05 am

The symptoms are:
-Upon power up the arpeggiator speed LED lights up

-After the unit warms up for a bit the other LEDs flash a bit, as do the digits on the screen. There's really no pattern to this, and it's pretty inconsistent. Sometimes it takes several minutes and others it starts doing this instantly

-The flashing lights are usually accompanied by a range of odd noises. Anything from a hum that rises or oscillates in volume (and varies in speed/pitch) to a tone playing (like one of the keys was pressed, but the time/pitch/etc. varies with no apparent pattern)

-Keys are unresponsive

-Buttons are unresponsive

-Cannot clear RAM by holding 5 and 8 on boot, or see firmware version by holding 1 and 2 on boot



What I've done so far:

-Checked out the power supply, and it's all good. The regulators are giving consistent voltages, and none of them fluctuate or spike. There's no AC present on any of the DC rails either, the whole PSU checks out: the caps, rectifier, regulators, and diodes seem good.

-Repaired a poorly done battery replacement job. It now has a socket for the internal battery, and it's soldered properly on the back of the board, with a fresh battery in it.

-Checked all of the wire connectors. Re-seated / cleaned them and wiggled them around to see if I could trigger some of the aforementioned symptoms through a bad connection or internally frayed wire. No dice.

NCChao1268
Junior Member
Junior Member
Posts: 106
Joined: Thu Mar 16, 2017 9:28 am
Gear: Kurzweil K2000 fully upgraded
Roland Juno 60
Roland JX-8P
Korg DW 8000
Polysix
Alesis SR-16
Yamaha DX7
Location: WA, USA

Re: Korg DW8000 not working, please help.

Post by NCChao1268 » Thu Mar 16, 2017 10:33 am

Hello HappyFunTimes, I've purchased a non working DW 8000 before thinking it could be fixed- I think I had the same issue as you. If it starts with the arpeggiator speed light lighting up followed by the rest of the lights later, it looks like a a board issue. Also if there are weird symbols and the numbers can't be changed, that means a board has gone bad and it usually can't be fixed. Usually if it's just the battery, you could still clear the RAM with 5 and 8, and change the number values with the buttons.

synthRodriguez
No Longer Registered

Re: Korg DW8000 not working, please help.

Post by synthRodriguez » Thu Mar 16, 2017 12:15 pm

Next thing I'd check would be the processor clock signal with a scope to make sure it's solid, not intermittent or weak.

Probe the clock pin on the main microprocessor and see what it looks like.

jxalex
Active Member
Active Member
Posts: 475
Joined: Wed Dec 07, 2016 6:05 am
Gear: enough
Location: Sweden

Re: Korg DW8000 not working, please help.

Post by jxalex » Thu Mar 16, 2017 8:24 pm

There can several things go wrong, but still ALL can be fixed.
got a service manual?

Check if all the microchips on the board get the voltages which they should be and their ground pins are not "floating". Thats for the start.

JHatzia
Junior Member
Junior Member
Posts: 121
Joined: Sun Jun 10, 2012 8:05 pm

Re: Korg DW8000 not working, please help.

Post by JHatzia » Fri Apr 28, 2017 2:12 am

Experiencing the same issue. I also replaced a poorly done battery replacement and have a new EPROM ver 12 on the way. Let's figure this out and get this issue solved.

JHatzia
Junior Member
Junior Member
Posts: 121
Joined: Sun Jun 10, 2012 8:05 pm

Re: Korg DW8000 not working, please help.

Post by JHatzia » Sun Jul 02, 2017 8:41 am

Sorry to double post..

I'm experiencing the exact same issue. I tried replacing the EPROM with no luck. The PSU in mine is fine as well, which makes me think it's CPU related. My unit will sporadically make these sweeping resonant filter sounds.. So it's making sound. However, the synth will not react if I enable the Tape switch. I'm pretty sure it's suppose to say "7APE"

I bought a logic probe in hopes I can teach myself to troubleshoot the CPU. Any pointers would be awesome.

JHatzia
Junior Member
Junior Member
Posts: 121
Joined: Sun Jun 10, 2012 8:05 pm

Re: Korg DW8000 not working, please help.

Post by JHatzia » Mon Jul 03, 2017 7:05 pm

Looks like the CPU isn't reseting properly. There is no spike of voltage on PIN 6 of IC35.

Mooger5
Expert Member
Expert Member
Posts: 1459
Joined: Tue May 06, 2008 5:11 pm
Location: Lisbon

Re: Korg DW8000 not working, please help.

Post by Mooger5 » Mon Jul 03, 2017 10:39 pm

No spike there, but a fast rising ramp instead, IMO. Check point A at pin 2 of IC40. It has to read +5VDC. Same voltage should appear at pin 6 of IC35, although delayed by a fraction of a second. If no voltage present there, something wrong with/around IC40. For confirmation, pin 25 of IC60 and pin 20 of IC47 have to receive the same reset signal.
Herrare umanum est.

JHatzia
Junior Member
Junior Member
Posts: 121
Joined: Sun Jun 10, 2012 8:05 pm

Re: Korg DW8000 not working, please help.

Post by JHatzia » Tue Jul 04, 2017 8:21 am

Thanks for the reply. Grounding a DVM to the TP-DG that's connected to C80, I probed each leg of IC40 and wasn't getting 5V.. However, Pin 6 on IC35 gets 5V. I get 5V from C80 as well.

Mooger5
Expert Member
Expert Member
Posts: 1459
Joined: Tue May 06, 2008 5:11 pm
Location: Lisbon

Re: Korg DW8000 not working, please help.

Post by Mooger5 » Tue Jul 04, 2017 10:25 am

Thats odd. Do you read 5v at point a? Look at the bottom right of that page and youll see that a inside a square is apoeer rail coming from the psu. It feeds the cpu ans every point a in the schematic. So pins 4,7,8,33 of ic35 and likweise pin 2 of ic40 should read the same. Check for conntinuitu between them
Herrare umanum est.

Mooger5
Expert Member
Expert Member
Posts: 1459
Joined: Tue May 06, 2008 5:11 pm
Location: Lisbon

Re: Korg DW8000 not working, please help.

Post by Mooger5 » Tue Jul 04, 2017 11:56 am

I have to repsir the arp slider in mine so ill be able to provide some readings. In about a week. I hate its guts literally. Opening that board eider than 90 degrees theres aleaus a short wire loom that gets disconnected and stays hidden among all the spaghetti. The synthvstill poeers up but acts all funny ofcourse.
Herrare umanum est.

JHatzia
Junior Member
Junior Member
Posts: 121
Joined: Sun Jun 10, 2012 8:05 pm

Re: Korg DW8000 not working, please help.

Post by JHatzia » Mon Aug 28, 2017 8:06 am

Looks like I misread these voltages, my apologies. I'm getting around 4.8V at all of the the pins mentioned in this thread as of now. Still the same issue.

Riinehart
Newbie
Newbie
Posts: 11
Joined: Mon Aug 28, 2017 10:05 pm

Re: Korg DW8000 not working, please help.

Post by Riinehart » Mon Aug 28, 2017 10:14 pm

I'm having the same issue as described in this thread (only arp speed light on, with occasional/non-sensical flickering of other LEDs), so I'm monitoring with great interest!

Unfortunately, although I'm good with an iron as long as I'm following simple instructions, I have no engineering background and no good understanding of schematics and how to really troubleshoot this kind of issue.

If anyone has any suggestions of things to try, please let me know. Especially if it can be of help to anyone else having the same issue ... like if I can help rule out something or other, just let me know what to test.

Many thanks!

JHatzia
Junior Member
Junior Member
Posts: 121
Joined: Sun Jun 10, 2012 8:05 pm

Re: Korg DW8000 not working, please help.

Post by JHatzia » Mon Aug 28, 2017 11:29 pm

If you move the joystick around does this cause any change? It will make the characters radically change on mine. I was thinking to swap all the tactile switches with new one in hopes that this will allow me to do the 5 + 8 reset.

EDIT: Replaced all tactile switches, didn't seem to change anything.

Riinehart
Newbie
Newbie
Posts: 11
Joined: Mon Aug 28, 2017 10:05 pm

Re: Korg DW8000 not working, please help.

Post by Riinehart » Tue Aug 29, 2017 3:24 pm

Weird, thought I subscribed to thread but didn't get any notification. Anyway, just saw this. Will test this evening when home and see if it's the same for me.

Post Reply