DX7 Ground Noise

Pulling out your hair? Don't know what to do or where to go? Ask in here.
Forum rules
READ: VSE Board-Wide Rules and Guidelines

If your Help request has been solved, please edit your first post in order to select the Image Topic Icon to let others know your topic has been solved.
Post Reply
User avatar
syntheticsolutions
Active Member
Active Member
Posts: 325
Joined: Sat Sep 17, 2011 11:04 pm
Real name: Ryan
Gear: Rhodes 78 Mk2, Jupiter 4, Juno 6, MS-10, CS-15, Opus 3, Machinedrum, RE-501, Roland Rack
Band: Lunar Modular
Location: UK

DX7 Ground Noise

Post by syntheticsolutions » Sat Feb 18, 2017 12:11 pm

I have a DX7 that recently started to put out this solid ground noise (about 1/4 the volume of the output).

Is there a way to easily find where the noise is coming from by tracing the ground? I have a multimeter.
It all looks visually in tact so am wondering if the noise could be coming from somewhere else but wanted to isolate the ground first.

The battery is healthy and the noise comes out of all outputs including the headphone and does not track pitch from the keyboard.
Replicants are like any other machine, they're either a benefit or a hazard. If they're a benefit, its not my problem.

User avatar
High_Treason
Newbie
Newbie
Posts: 14
Joined: Thu Nov 13, 2014 1:33 am
Gear: Casio CZ-1, CZ-5000, RZ-1.
Yamaha MU90R, SW1000XG.
Korg O1R/W
Roland SCC-1
Location: Hull, UK
Contact:

Re: DX7 Ground Noise

Post by High_Treason » Sun Feb 19, 2017 8:25 pm

I've heard of DX7's not having their ground connected internally and in the case of some, using a 2-Pin plug so there is no ground anyway (as is the case with mine) so noise can be rather loud.

In my case, I removed the ground connection from my audio cables a long time ago so the problem goes away (as my house has an earth fault anyway, so there's a huge noise ground loop I can't stop) as you're only connecting the signal. Anything that references ground should still be OK, signal-wise, because ground and neutral should be tied together somewhere in your electrical system... Usually. This only goes for audio signal cables, do not disconnect the ground to any electrical cables because, as I am sure you know, that would be dangerous.

My method was to put tape over the outside of the RCA adaptors on my mixer and spread the four edges of the RCA connector on the cable a little so only the central pin plugs in.

You might want to save this as a last resort though as butchering cables sucks if you have to go back later and there may be something I have missed entirely that another member might have knowledge of.

User avatar
synthRodriguez
Supporting Member!
Supporting Member!
Posts: 369
Joined: Sat Apr 25, 2009 11:46 pm
Real name: Scott
Gear: Moog - Roland - Yamaha
Location: Western Ohio

Re: DX7 Ground Noise

Post by synthRodriguez » Mon Feb 20, 2017 9:35 pm

Don't know if this might help, but I had 60 Hz hum on all outputs like that in an SY99 when the display back light connection didn't have a solid ground. It happened when I was working on it though, not just suddenly on its own.

Just a thought.

jxalex
Active Member
Active Member
Posts: 475
Joined: Wed Dec 07, 2016 6:05 am
Gear: enough
Location: Sweden

Re: DX7 Ground Noise

Post by jxalex » Wed Feb 22, 2017 7:51 am

syntheticsolutions wrote:I have a DX7 that recently started to put out this solid ground noise (about 1/4 the volume of the output).

Is there a way to easily find where the noise is coming from by tracing the ground? I have a multimeter.
It all looks visually in tact so am wondering if the noise could be coming from somewhere else but wanted to isolate the ground first.

The battery is healthy and the noise comes out of all outputs including the headphone and does not track pitch from the keyboard.

I suggest probing the voltage line rails for a ripple with oscilloscope. There should not be pulsation with such hum. If you do not have oscilloscope handy for trying then amplifier input (through 10k resistor and 10uF capacitor) is fine too. OR just a pair of headphones ( and 1k ohm resistor and 10uF capacitor in series before headphones). ANd so You listen what is here and there.

So if the same hum when probing is on the +15V, -15V, +5V voltage rails too, then the big capacitors in a power supply have gone bad, which means increased pulsation, thus the audible hum at all outputs.
Other situation can be that solder joints are gone bad in power supply unit -- check the solder on the diode rectifier (half of it does not work perhaps?) or capacitors in the power supply and so the intermittent contact.
Also - bad grounding -- some ground wires are not seated correctly or joint is loose?

Post Reply