Roland U-220 help

Pulling out your hair? Don't know what to do or where to go? Ask in here.
Forum rules
READ: VSE Board-Wide Rules and Guidelines

If your Help request has been solved, please edit your first post in order to select the Image Topic Icon to let others know your topic has been solved.
Post Reply
User avatar
Supporting Member!
Supporting Member!
Posts: 249
Joined: Sun Nov 19, 2006 3:30 am
Gear: SH-2, JV-880, D-110, M-1000, CS-15, FR-777, FR-XS, ESQ-1
Location: Berkshire, NY

Roland U-220 help

Post by 30h5 » Fri Nov 16, 2018 5:30 pm

Hello, just curious if anyone has any ideas on this. I bought a cheap Roland U-220 and it arrived in less than working condition. When I power it up, the LCD screen lights up, but has no information. Additionally, the unit does not appear to respond to Midi as indicated by a lack of sound output and by the midi receive light not engaging when notes are sent. I have opened up the unit and nothing appears to be un-socketed or out of place. Because I got it so cheap and because the synth itself is not very desirable, I am not inclined to have it troubleshooted and serviced by a tech. As such, I thought I would try and tinker with it myself despite my total lack of DYI electronic skills (I don’t even have a soldering iron at this point in time). The previous owner did say that the synth displayed characters on the screen when he shipped it and he was able to navigate the menus, but that he did not have any midi equipment to test it with. Thus, I think it may have been operable when he shipped it and due to his bad packing job, the synth experienced something on the way to me which rendered it inoperable by the time I received it.

Does anyone have any ideas of where I should begin looking or things to check? I do have a multimeter FWIW.

Many thanks

User avatar
Senior Member
Senior Member
Posts: 977
Joined: Sun Sep 26, 2010 10:20 pm
Real name: Francis
Gear: Roland JX-3P, D-50, JP-8080.
Korg Kaossilator, MicroKorg,
Yamaha Motif Rack.
Location: French Canada

Re: Roland U-220 help

Post by fh991586 » Mon Nov 19, 2018 6:42 pm

My first guess would be to change the internal battery (it's an easy operation with a common part):

While the unit is open, you could check that the screen is well connected to the main board: a loose connection might be the cause of nothing appearing on it!

You will have to upload the sound files through midi, as there is no factory reset option on this unit. A "handshake" type would be a good idea: midi in & out connected to computer for a complete communication loop! Let's just hope the midi works after you get the screen back on tracks...

Owner's manual: ... 62ae3a.pdf
Service manual: ... _NOTES.pdf
Available for sale:
-DSI Mopho
-TherapSID mk1
-Chamber of Sounds Jupiter III (mk1) & Jupiter T (mk1)
-The Complete DX7- Howard Massey (with original enclosed sounds on soft disks)

Post Reply